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1 SCOPE  
 
ArcView GIS® 3.3, developed by Environmental Systems Research Institute®, Inc. (ESRI®), is a 
geographic information systems (GIS) software product that allows the user to author, visualize, 
analyze, query, map, and organize geographic information.  The extensions/utilities that will be 
validated in this test plan and report are Import71, Projection Utility, Spatial Analyst®, 
Geoprocessing, Import Data Source, Export Data Source, Add XY, Data Query, Grid to XYZ 
Text file, and Field Calculation.  These products cover limited functionality as listed below. 
 

Geographic Analysis 
Data Conversion 
Data Editing and Compilation 
Data Management 
Visualization 
Geoprocessing 

 
The software validation test plan and report of ArcView GIS® 3.3 should confirm that the 
software can correctly perform the above-listed functions with original data, maintaining 
geospatial relationships and coordinates.  This list of extensions is a subset of the entire list of 
extensions available.  It was chosen as a representative sample of commonly used functions 
necessary for processing data from start to a finished product. 
 
 

2 REFERENCES 
 
Environmental Systems Research Institute, Inc.  “Using ArcView GIS.”  Redlands, California:  
Environmental Systems Research Institute, Inc.  2002. 
 
–––––.  “ESRI GIS Mapping Software ArcView 3.x.”  Redlands, California:  Environmental 
Systems Research Institute, Inc.  <http://www.esri.com/software/arcview/arcview3x.html>  
(February 2, 2006a). 
 
–––––.  “ArcView 3.x Brochure.”  Redlands, California:  Environmental Systems Research 
Institute, Inc.  <http://www.esri.com/library/brochures/pdfs/arcgisbro.pdf>  (February 2, 2006b). 
 
Texas Natural Resources Information System (TNRIS).  “Helotes Data.  USGS Digital Elevation 
Model Data.  Scale:  1:24,000.  <http://www.tnris.org/index.htm>  (February 2, 2006). 
 
–––––.  “Helotes Data.  TXDOT 015 Urban Files, Bexar County.  2002.  
<http://www.tnris.org/index.htm>  (February 2, 2006). 
 
–––––.  “Helotes Data.  TXDOT 010 Urban Files, Bandera Country.  2002.  
<http://www.tnris.org/index.htm>  (February 2, 2006). 
 

3 ENVIRONMENT 

3.1 Software 
ArcView GIS 3.3 is a commercially developed software application by ESRI for advanced GIS 
mapping and analysis.  ArcView GIS “can use data from virtually any source and across most 
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popular computing platforms.”  (ESRI, 2006b)  The following ArcView extensions are required to 
perform validation testing activities: 
 
ArcView 3.3 has the following software extension/utility applications: 
 
• Geoprocessing 
• Add XY 
• Import Data Source 
• Export Data Source 
• Grid to XYZ Text file 
• Projection Utility 
• Spatial Analyst 
• Import71 Utility 
• Data Query 
 
Operating System:  Microsoft® Windows® 2000 

3.2 Hardware 
• CPU speed of 1.0 GHz or higher 
• Pentium or higher processor 
• 24 MB or higher memory/RAM 
• 200 MB minimum swapspace 
• 171 MB free disk space 
 
 

4 PREREQUISITES 
 
Running ArcView GIS 3.3 requires installation of the commercially available software, per the 
developers’ User’s Manual. 
 
 

5 ASSUMPTIONS AND CONSTRAINTS 
 
The user of ArcView GIS 3.3 is assumed to be familiar with GIS and geospatial data sets. 
 
Data supplied for this software validation plan and test are available for download from 
Texas National Resources Information System website.  Metadata for each set of data are 
contained in the individual data file folders on the attached CD of downloaded data.  All data 
compressed in ZIP files have been uncompressed for use in this software validation test. 
 

6 TEST CASES 
 
The test cases described in this section involve extensions that provide the user specialized GIS 
functionality.  The number of extensions and/or scripts available is not limited to those used 
here, because some are provided with the software or can be created as needed by users or 
ESRI, and are available to the public on the ESRI website (http://arcscripts.esri.com/).  Some 
extensions ESRI sells are separate products that expand the capabilities of GIS processing and 
analysis.  ArcView Spatial Analyst, is one of these specialized software packages used in this 
limited validation.  Each test covers one or more extensions or utilities.  All extensions and 
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utilities used in the test are provided with the ArcView GIS 3.3 software package, except 
ArcView Spatial Analyst.  All tests combine to make a GIS project.  The tests involve locating, 
managing, creating, editing, geoprocessing, displaying, querying, and viewing raster and/or 
vector data. 

6.1 Test Case 1 – Workspace, Manage Data, Create and Edit Vector Data  
ArcView GIS is employed to organize, find, and use GIS data.  ArcView contains a 
comprehensive collection of geoprocessing functions including tools for data conversion, data 
management, coverage processing, vector analysis, statistical analysis, and geocoding. 

6.1.1 Objectives 
 

● Demonstrate that ArcView GIS can be used to set the working directory for the 
project, search for and discover GIS data on the local network, create and edit GIS 
data on the local network, and manage the data. 

● Demonstrate that ArcView GIS functions correctly convert, process, and prepare 
data for use with other ArcGIS products. 

6.1.2 Test Input 
 
(1) HELOTES - DEM, 2998270g.dem 
(2) BEXAR - TxDOT Urban Data, urban015_dd.e00 
(3) BANDERA - TxDOT Urban Data, urban010_dd.e00 
 

6.1.3 Test Procedure 
(1) Open ArcView GIS 3.3.and open a new View. 
 
(2) Under File, select Set Working Directory (Figure 1a).   
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Figure 1a.  Set Working Directory 

 
A window opens showing the location where newly created data and temporary files will be 
saved.  The default location is the Temp file where ArcView GIS is installed (Figure 1b).   
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Figure 1b.  Default Directory 

 
Change the location to the data_gis_validation directory. 
 
(3) Using the Add Data button, search for the location of the data listed in Test Input, 

Section 6.1.2. 
 
ArcView GIS does not recognize the file formats having the extensions .dem and .e00.  These 
files will have to be converted to formats that ArcView GIS recognizes.  The conversion will be 
done using the Import Utility, Import71 or Import Data Source, in the following steps. 
 

● Use the standalone Import71 Utility to convert the ArcINFO interchange files to 
ArcINFO coverages compatible with ArcView GIS.  The utility is part of the ArcView 
Program group that is shipped with ArcView GIS 3.3. 

 Open the Import71 Utility in the ArcView program group by clicking on the 
Microsoft Windows Start icon on the standard toolbar.  Select Programs > ESRI > 
ArcView GIS > Import71 (Figure 2a).   

 



6 

  

Figure 2a.  Path of Import71 Utility 

 
● Use the Import71 Utility dialog window to browse to the location of the TxDOT 

files, and select the ArcINFO Interchange file (.e00) for the Bexar/Helotes 
TXDOT Urban Data (urban015_dd.e00) as the Export Filename.   

● Click OPEN, then use the Output Data Source Browse to indicate the directory 
location.  When you click on the Browse button, the path defaults to the directory 
of the import file.  The imported file will be saved in the tx_dot_a folder (Figure 2b). 

 

 

Figure 2b.  Import71 Utility Dialog Window 
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● In the Import Utility Window, name the urban015_dd.e00 file txdot_e0a 

(Figure 2b).  When the process is complete, you will receive a message showing 
the path and whether the conversion is complete.  Click OK.   

● Repeat this import procedure for the Bandera urban010_dd.e00 file.  Save the file 
as txdot_e0b in the txdot_b folder. 

 
In ArcView, use Import Data Source to import the Digital Elevation Model (DEM) into 
ArcView GIS.  File > Import Data Source > USGS DEM. 
 

● Open the File Menu, select Import Data Source, and then select USGS DEM 
(Figure 3a). 

 

 

Figure 3a.  Import Data Source Dialog Window 

 
 In the Import USGS DEM files window, select the file 2998270g.dem in the 

helotes_DEM directory in the data_gis_validation directory as the USGS DEM 
input file. 
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● ArcView should have defaulted to the data_gis_validation directory as set in Test 
Procedure 2 above.  In the Output Grid Window, name the output grid file 
helotes_dem and save it in the helotes_DEM folder in the data_gis_validation 
directory (Figure 3b). 

 

 

Figure 3b.  Defaults to Work Directory 

 
● When the Import Data Source Dialog window displays “Add grid as theme to 

View?” click on Yes. 

(4) When ArcView opens a grid file in the View Window, it defaults to nine classification 
bins based on the value of each grid cell, plus a “no data” class.  The classification bins 
are represented by a graduated color ramp where the darkest color is assigned to the 
highest number (Figure 4a).   
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Figure 4a.  Grid Default Settings 

 
(5) Using the Legend Editor, the number of classification bins can either be increased to 

show more detail or decreased to show less detail.  The color ramp can be replaced to a 
grey scale where the highest elevation will be represented by the lightest color. 

 
● Reclassify the grid and revise the color ramp. 

− Double-click on the theme name (Helotes_dem) in the View’s Table of 
Contents (TOC) to open the Legend Editor. 

− Click on the Classify Button and change the number of classes to 12; click 
OK.  The Legend Editor now represents the values separated into 12 
classification bins.  Update the View by clicking on Apply in the Legend Editor 
(Figure 4b). 
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Figure 4b.  Edit Grid Classification Bins 

 
− In the Legend Editor, click on the Color Ramps drop-down menu and select 

grey monochromatic, then click on the ramp button above the Color Ramps 
menu (arrow in Figure 4c) that has two arrows indicating top to bottom and 
bottom to top to switch the colors of the ramp (Figure 4c). 
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Figure 4c.  Alter Color Ramp 

 
− Click Apply to accept the changes, and notice the DEM grid where dark areas 

are low elevations and light areas are higher elevations.  Close the 
Legend Editor. 

● Verify the helotes_dem file location by clicking Add Theme button with the Data 
Source Types set as Grid Data Source and locate the helotes_dem file.  The 
source of the data can also be checked in Theme > Properties. 

− Click on the Helotes_dem theme in the TOC to make it active, if it is not 
already. 

− Click on the Theme Properties button.  The path of the Source should be the 
path to the location of the grid file.  Notice the other information about the grid 
that is available in this window (Figure 5). 
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Figure 5.  Theme Properties > Source 

 
− Close the Theme Properties and uncheck the Helotes_dem box in the 

View TOC. 

 
(6) Create a new shapefile (highways.shp) from the ArcINFO coverage txdot_e0a, use the 

Build Query Tool to create another new shapefile from highways.shp containing only 
the General Feature of Highway (bexar_hwy.shp), edit the bexar_hwy shapefile to 
remove highway segments, and add XY Data to the Highway Attribute Table. 

● Create a Shapefile from an ArcINFO coverage. 

− From the txdot_a Directory, select the ArcINFO coverage, txdot_e0a and 
open in the View. 

− With the txdot_e0a coverage active in the View TOC, select Theme > Convert 
to Shapefile. 

− The Convert Txdot_e0a Window opens to the Work Directory 
(data_gis_validation) with a default shapefile, theme1.shp (Figure 6).   

− Name the shapefile highway.shp and click OK. 
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Figure 6.  Convert to Shapefile Default Path 

 
− When the conversion is complete, the Convert to Shapefile Message 

Window will ask whether you want to add the new theme to a View.  
Select Yes. 

− Highway.shp has been added at the top of the View TOC.  Check the box to 
make it visible.  It should completely overlap the ArcINFO coverage. 

− Having the highway.shp theme active, select Theme > Properties to check 
that the saved location of the new theme is the same as the selected location. 

− Deselect the ArcINFO txdot_e0a coverage to make it invisible. 

− Insure the highway.shp theme is active, and click on the Open Theme > Table 
button.  The Attribute Table for highway.shp will open. 

 
(7) Use a query expression ([Feature_general] = “Highway”) to select features by 

attribute:  Query Builder > Select from Set > New Set > Save as Shapefile. 
 

● Click on highway.shp in the TOC to ensure that it is active. 

● Click on the Query Builder button.  The query can be built by clicking on fields, by 
clicking on operators and values, or by typing it in.  From the Fields list, double-
click on [Feature_general].  Click on the equals operator (=) and then type in 
“Highway” with the quotation marks. 
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● Click on New Set.  The records meeting the expression criteria will be highlighted 

in the Attribute Table and will be selected in the View. 

● The number of records selected is displayed in the table’s tool bar (arrow, 
Figure 7a). 

 

Figure 7a.  Query Builder Dialog Box 
 

● Confirm that only Highway in Feature_general is chosen.  Make the Attributes of 
Highway.shp Attribute Table active.  Click on the Promote icon (arrow directed 
upward, next to Query button).  Use the Attribute Table scroll bars to view the 
Feature_general field (Figure 7b). 
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Figure 7b.  Verify Selected Feature Information 

 
● Close the Query Builder Tool and make the View active.  In the Theme menu, 

select Convert to Shapefile.  Save the file as bexar_hwys.shp in the 
data_gis_validation directory, click OK, and add to the View. 

● Open the Attributes of bexar_hwy.shp table and scroll through to see that the 
Feature_general field is only Highway.  Click on the bexar_hwy.shp name in the 
TOC; use the Identify tool to select a section of highway in the view, and review 
the information in the Results window (Figure 7c). 
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Figure 7c.  Identify Tool to Verify Feature Information 

 
(8) Edit Theme to remove disconnected features.  Theme > Start Editing > Select Feature 

> Stop Editing > Save Edits.  Use Add XY extension to add x and y coordinates to a 
theme’s Attribute Table. 

 
● Bexar_hwy.shp theme should be active.  Keep the theme Attribute Table open. 

● Click on Theme > Start Editing. 

● Use the Selection Tool (square box icon), and draw a rectangle around a feature 
or a group of features that do not appear connected to the highways.  The selected 
features will be highlighted in the Attribute Table and will be encased by eight 
solid black boxes in the View (Figure 8a,b).  These boxes can also be used to 
change size and length of a feature being edited. 
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Figure 8a,b.  (a) Edit Theme by Selecting Features in View.  (b) Edit Handles of Selected 
Features in Figure 8a. 

 
● If part of the highway you wanted to keep is deleted, click Edit > Undo Feature 

Edit and the last edit will be added back in the View and Table. 

● When edits are complete, click on Theme > Stop Editing > Save Edits.  If the 
original file needed to be saved intact as it was before editing, use the Save Edits 
As option.  The original file is not needed here, so save edits to the current theme. 

● The Add XY extension calculates the x and y coordinates for a point or polygon in 
the same coordinate system as the Shapefile or ArcINFO coverage without being 
in the Edit Mode.  When used on a line, the point is located at the center of the 
line between two end nodes.  Other user-created extensions are available for 
download at the ESRI website that will add coordinates for line end points (FNODE 
and TNODE) as well as the vertices of polylines and polygons.  Click on 
bexar_hwy.shp to make it active, if not already.  Click Theme > Add XY.  ArcView 
GIS adds two fields or columns to the end of the Attribute Table:  one named 
x-coord and one named y-coord (Figure 8c). 

 

(b) (a) 
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Figure 8c.  Add X and Y Coordinates to Attribute Table 
 
(9) Use the Geoprocessing Wizard to merge two themes together, creating a new Theme:  

View > Geoprocessing Wizard > Merge Themes Together.  Add both highway.shp 
and bandera_rds.shp to the View, if not listed in the TOC. 

 
Click on the Highway.shp theme in the TOC to make it active, if not already active.  In the View 
Menu, select Geoprocessing Wizard.  The eligible processes for the selected theme will only 
be available.  Choose Merge Themes Together.  Click Next. 
 

● The GeoProcessing Window opens with a list of eligible themes and their feature 
type.  Select Highway.shp as the first Input Theme (Figure 9a). 

● Hold down the Shift key and select bandera_rds.shp as the second input Theme 
in the same selection box (Figure 9a). 

● In the Use Fields From dropdown menu, select highway.shp – Polyline 
(Figure 9a). 
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Figure 9a.  Merge Two Themes With Geoprocessing Wizard 
 

● Name the output file all_roads.shp and save it in the data_gis_validation directory.  
The path to the directory should already be set. 

● Click Finish. 

● When ArcView completes the merge, the new theme (all_roads.shp) is added to 
the TOC.  Activate the all_roads.shp theme.  The single theme overlays the 
highway.shp and the bandera_rds.shp themes (Figure 9b). 

 

 

Figure 9b.  Verify Merged Theme 
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● Check the location of all_roads.shp in the Theme Properties Source (Theme > 
Properties). 

 
(10) Reproject themes using File Menu > ArcView Projection Utility. 
 

● In the View TOC, check the highway.shp theme and the helotes_dem grid.  As 
mentioned previously, Helotes is in Bexar County and should be aligned in the 
View Frame.  They are not both in the same View frame, because they are in 
different coordinate systems with different horizontal units of measurement.  
Because highway.shp is the same as txdot_e0a, but in a different format, the 
coordinate system will be identical for both.  The Projection or Spatial 
Information of the themes and/or grid should be available in the Metadata file or, 
in this case, a README text file included with the data files. 

− Use the Microsoft Windows Explorer, or similar utility, to locate the 
readme_dd.txt file that was extracted from the 015urban_dd.zip file.  Open the 
file in Notepad or similar utility.  Section II of the readme_dd.txt file gives the 
information that the file is in geographic, horizontal units of decimal degrees, 
and in North American Datum of 1983 (NAD83) (Figure 10a). 

 

 
 

Figure 10a.  Section II of Readme_dd.txt 
 

− The helotes_dem is in Universal Transverse Mercator (UTM) Projection, 
Zone 14, Horizontal and Z units, meters; Horizontal Datum of NAD27, the 
ordr9dem.txt (Figure 10b) file, indicates the horizontal and vertical datums are 
invalid, but TNRIS verified the datum information to be the same for all the 
7.5′ DEMs. 
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Figure 10b.  Ordr9dem.txt File Contained in 2998270g.zip (Helotes DEM) 
 

● UTM is more commonly used for local mapping, so the highway.shp file will be 
reprojected to align with the helotes_dem. 

● File > ArcView Projection Utility.  Select the ArcView Projection Utility located 
in the File menu.  In the Step 1 window, browse to the location of highway.shp, 
select the file, and click Open.  The highway.shp file is now shown in the Step 1 
window.  Click highway.shp to highlight; click Next button. 

● Step 2 of the ArcView Projection Utility asks that the shapefile’s current 
coordinate system be input.  The coordinate system that is listed is geographic, 
decimal degrees, NAD27 datum (Figure 10c), which is the default when ArcView 
GIS is unable to read a projection for a file. 

 

Figure 10c.  Default Coordinate System of Projection Utility 

 
● Located at the top of Step 2 is the box Show Advanced Options.  Check the box.  

Three tabs become available to customize the projection, if necessary. 

● To set the current coordinate system for highway.shp, click on the dropdown list for 
Name.  Select the GCS_North_American_1983 [4269]; the units should remain at 
Degree.  Click Next. 
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● Select the Datum Tab from the Advanced Options.  A transformation will be 
required for ArcView GIS to calculate NAD83 to NAD27.  Under Geographic 
Transformation, select NAD_1983_to_NAD_1927_NADON (Figure 10d) (the “to” 
in the transformation description can also be a “from” as the transformation works 
in either direction). 

 

Figure 10d.  Advanced Options of Projection Wizard 

 
● Another ArcView Projection Utility window will open to inform the user that a 

coordinate system has been specified for the shapefile and asks whether you 
would like to save the coordinate system information.  When Yes is selected, 
ArcView will create a projection file (.prj) in the same name as the shapefile.  
Select Yes. 

● The ArcView Projection Utility automatically changes to Step 3.  Select the new 
coordinate system for the shapefile.  Change the Coordinate Type to Projected.  
The default projected coordinate system is World_Mercator [54004], with the 
units, meters.  Open the dropdown list of projection names.  Scroll until you find 
NAD_1927_UTM_Zone_14N [26714] and select (Figure 10e).  Click Next. 

 

 

Figure 10e.  Step 3—Input of New Coordinate System 



23 

 
● The Step 4 window asks the location and name for the new shapefile.  Open 

Browse.  The directory should be the data_gis_validation directory; rename 
newshapefile.shp to hwy_u14n27.shp.  Select Save.  After checking on the path 
and revised name in Step 4, select Next. 

● The ArcView Projection Utility Summary Window lists all the information from 
the Input Shapefile and the Output Shapefile.  If the information is correct, select 
Finish.  If at any time file coordinate system or names need editing, use the Back 
button on any of the Projection Utility windows. 

● The ArcView Projection Utility Progress Window will open so you can observe 
the transformation progress.  When the transformation is completed, the ArcView 
Projection Utility Complete Window opens.  Click OK.   

● A Projection Utility Window will open asking whether the new shapefile should 
be added to the View.  Click Yes.  The Add Projected Data Window will open in 
the directory of the newly projected shapefile (Figure 10f); select the 
hwy_u14n27.shp file and click OK. 

 

Figure 10f.  Add Projected Data Window 

 
● Another Projection Window will open asking whether you want the newly 

projected shapefile opened in one of the current Views or you want to open a New 
View and add the new file.  Select View1 and click OK. 

● Click the Check Box for hwy_u14n27.shp, then click on the helotes_dem in the 
View’s TOC.  Select the Zoom to Active Themes button.  The reprojected 
highway theme now aligns with the helotes_dem (Figure 10g). 
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Figure 10g.  Verify Projected Data Alignment 
 

● Use the Zoom In tool to check the alignment (Figure 10h) and the Zoom Out tool 
to perceive the size of the Helotes Quadrangle in relation to Bexar County 
(Figure 10i). 

Figure 10h.  Zoom In—Scrutinize Alignment 
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Figure 10i.  Zoom Out—Perceive Relationship of Helotes Quadrangle and Bexar County 

 
● While holding down the Shift Key, click on the names all_roads.shp, 

bandera_rds.shp, txdot_e0b, bexar_hwys.shp, highway.shp, and txdot_e0a.  
Select Edit > Delete Themes.  A window will open asking, “Are you sure you want 
to delete theme all_roads.shp?”  Click Yes to All. 

(11) Create a new vector polygon theme, calculate the area of the new theme, use the new 
theme polygon to extract features from a line vector theme, and save the extracted line 
data to another new theme. 

 
● With the Project View active, click on the View Menu > New Theme.  In the New 

Theme window, select Polygon as the Feature Type and click OK.  The New 
Theme window now prompts for the name of the new theme and location for 
saving the new theme.  Rename theme1.shp to helotes_poly.shp and save in the 
data_gis_validation directory. 

● A new theme will open in the TOC with the symbology of a filled polygon and in 
Edit Mode (check box is dashed).  The Rectangle Tool is automatically moved to 
the top of the Drawing Tools (arrow, Figure 11a). 
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Figure 11a.  Drawing Tool Used to Create New Theme 

 
● Double-click on helotes_poly.shp name to open the Legend Editor.  Double-click 

on the symbol.  The Color Palette will open or if open, will come to the front.  
Select the Fill Palette button (the pouring bucket).  Select the first sample (white 
square with black outline), which represents a polygon with no fill color or pattern.  
Click the Outline window and Select 2 for the thickness of the polygon outline.  
Select the paintbrush button to open the Color Palette.  Open the color dropdown 
menu and select Outline; click on the color Red.  The Legend Editor should be a 
rectangle with a red outline (Figure 11b). 
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Figure 11b.  Edit Theme Symbology 

 
● Click Apply and the theme name will reflect the new symbol.  Close the 

Legend Editor. 
● Zoom In to the extent of helotes_dem.  Click the Rectangle Tool, click on one 

corner of the helotes_dem in the View, and drag the rectangle to the opposite 
corner.  Release the mouse button.  Any edits can be made by using the pointer on 
a black square to adjust the outline.  When the polygon outline is complete, click 
Theme > Stop Editing > Save the Edits. 

● Open the helotes_poly.shp Attribute Table.  The table only has one record and 
two fields/columns.  Make sure the Project View is active as well as 
helotes_poly.shp.  Click Theme > Add XY.  The Attribute Table now has the x 
and y coordinates for a point in the center of the polygon. 

● Make the helotes-poly.shp Attribute Table active.  Click Table > Start Editing.  
The Field Names are no longer italicized.  Select from the Table Edit menu, Add 
Field.  The Field Definition window will open.  In the Name Box, put in Area.  
Type will remain at number and width will remain at 16.  Change the Decimal 
Places to 4 (Figure 11c). 
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Figure 11c.  Adding Data to Attribute Table 

 
● Click OK. 

● The Area Field heading is added and selected.  Select the Edit Tool from the 
Table Tool Bar (“I” with the upward arrow).  Click in the empty bordered space to 
make it active with a flashing cursor. 

● Click on the Calculator Button (next to the sum symbol).  The Field Calculator 
window opens, and the space selected in the previous step now has a 0.0000 
entered.  Above the dialog box, “[Area] =” is the beginning of the calculation dialog 
(the area field is active).  Double-click on [Shape] and this is added to the dialog.  
Click behind the bracket and add “. (period)ReturnArea,” shown in Figure 11d. 
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Figure 11d.  Field Calculator Used to Add Data to Attribute Table 

 
● Type should be number; click OK.  The area in map units of meters is added to the 

Attribute Table.  Select Table > Stop Editing > Save Edits.  The heading names 
are now italicized.  Click on the Select None button and close the 
helotes_poly.shp Attribute Table. 

● Use the polygon helotes_poly.shp to extract the highway Feature_General 
features of hwy_u14n27.shp that are within the boundaries of helotes_dem. 

− Click on hwy_u14n27.shp name to make the theme active.  Click the Table 
Button to open the Attribute Table for hwy_u24n27.shp.  Click the Query 
Builder button.  Enter the ([Feature_ge] = “Highway”) in the Query Builder 
Dialog window as used earlier.  Click New Set.  The records that satisfy the 
query are now selected in the Attribute Table and in the Project View 
(Figure 11e). 
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Figure 11e.  Query Builder Used to Select Theme Features 

 
● Close Query Builder Dialog window. 

● Select helotes_poly.shp in the TOC to make it active. 

● Select View > Geoprocessing Wizard > Clip One Theme Based on Another.   
− Open the Geoprocessing Wizard in the View menu, and select Clip One 

Theme Based on Another operation.  Click Next. 
− Select hwy_u14n27.shp as the Input Theme to Clip.  The check indicates that 

only selected features will be clipped from the Input Theme, and the total 
number of features in the Input Theme are listed below.  Keep the box 
checked.  Select helotes_poly.shp as the Polygon Overlay Theme.  Specify 
the Output Directory Location in the data_gis_validation directory and name 
the theme helotes_hwy.shp.  Click Finish.  Helotes_hwy.shp will be added to 
the Project View.  Change the color of the helotes_hwy line symbol for better 
contrast with yellow and green symbol colors.  Helotes_hwy.shp overlays the 
selected highways from hwy_u14n27.shp.  Click the Select None button; close 
hwy_u14n27.shp Attribute Table.  Uncheck helotes_poly.shp and 
hwy_u14n27.shp.  Helotes_hwy.shp is the only highway theme visible.  Zoom 
out to verify that helotes_hwy.shp was clipped from hwy_u14n27.shp 
(Figure 11f). 
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Figure 11f.  Verify Extent of Clipped Theme 

 
● Select Helotes_poly.shp and hwy_u14n27.shp while holding down the Shift Key to 

make active.  Click Edit > Delete Themes and Yes to All in the next window.  
Click the Return to Previous Extent button to return to previous scale of the 
DEM.  Uncheck helotes_hwy.shp. 

6.1.4 Expected Test Results 
● The Set Working Directory will set the default directory for saving data. 

● The Import71 standalone utility will change the ArcINFO Interchange format to 
ArcINFO coverage.  The Import Data Source will convert a USGS DEM to an 
ArcINFO grid. 

● The grid data will be reclassified, and editing the color ramp will increase the 
visibility of the cell elevation data. 

● ArcView GIS will readily convert ArcINFO coverages to shapefiles creating the 
Attribute Table containing all the information from the original file format. 

● The Query Builder will extract the desired data from a shapefile and create a new 
shapefile with the queried data. 

● In ArcView GIS, shapefiles can be edited in a Project View or by editing the 
Attribute Table.  The Add XY tool will add coordinates to the Attribute Table. 

● The Geoprocessing Wizard will create a new theme by merging two separate 
themes and will create one Attribute Table. 

● The ArcView Projection Utility will create a projection file for a theme, and then 
change the projection and datum, making a new shapefile to align with a 
base image. 
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● A new polygon shapefile will be created using the New Theme tool.  The Field 
Calculator will be used to calculate the area of the new polygon and will be used 
to clip a shapefile to the extent of the base image. 

6.1.5 Test Results 
The default directory was reset using the Set Working Directory tool.  The E00 and the DEM file 
format were converted to ESRI ArcINFO format using the Import71 utility and the Import Data 
Source, respectfully.  The data classification of the ArcINFO grid was changed to show more 
elevation ranges in the grid, and the color legend was changed to reflect high areas as white 
and low areas as black. 
 
The ArcINFO coverage was converted to a shapefile and retained all information in the new 
Attribute Table.  A new subset shapefile was created using the Query Builder, and the 
information for the selected features was retained in the new Attribute Table.  The shapefile was 
edited in the Project View using the Edit Theme tool, and editing was also accomplished by 
editing the Attribute Table.  Coordinate data was added to the Attribute Table using the Add XY 
tool.  Two shapefile themes were merged to a single shapefile theme with an Attribute Table 
containing data from both files using the Geoprocessing Wizard. 
 
A projection file (.prj) was created for a shapefile theme and then reprojected to a new 
coordinate system using the Projection Utility. 
 
A new polygon theme was created to the extent of the ArcINFO grid.  The Field Calculator 
added the area of the polygon to the Attribute Table.  The polygon was used to create a new 
subset of the ArcINFO coverage theme using the Geoprocessing Wizard. 
 
 
 
Results verified by:  ___________________________     Date:  _________________ 
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6.2 Text Case 2 – Spatial Analyst Extension 2.0a 
The Spatial Analyst Extension is a separate program to expand the capabilities of ArcView GIS 
allowing the user to better understand spatial data relationships and allowing new types of 
analysis using raster data.  Spatial Analyst analyzes data by zones, distance, and 
demographics and can be used for defining land use, analyzing hazards and hydrologic basins, 
and visualizing areas from a specified location.  Spatial Analyst has tools for creating contours 
as well as histograms and can interpolate grids from point or line data. 

6.2.1 Objectives 
ArcView GIS will be used to create a Shapefile from an Event Theme using x 
and y coordinates. 
 
Spatial Analyst Extension 2.0a with ArcView GIS 3.3 can be used to perform the 
following functions. 
 

● Use an elevation grid to create an Aspect grid of the degree of steepness from 
each cell to its neighbor. 

● Use an elevation grid to create a Slope grid representing the maximum rate of 
change for each cell to its neighbor. 

● Use an elevation grid to create a Hillshade that can be used as a hypothetical 
illumination of a surface for analyses or display.  

● Use elevation grid cell values to create Elevation contours at a selected interval 
from a selected base number. 

● Create a Grid from raster data using the Query Dialog Builder. 
● Create a Grid using a point feature theme and export the grid to a XYZ text file. 

6.2.2 Test Input 
(1) helotes_dem from Section 6.1  
 
(2) sample_water_wells.dbf [This dbf file was extracted from the list of wells with 

stratigraphic contacts Alvin Schultz, consultant to San Antonio Water Systems supplied 
for another project and was saved as a DBF 4 (dBASE IV) file using Microsoft Excel®.  
This file is not available online.] 

6.2.3 Test Procedure 
(1) Open ArcView GIS 3.3 if it is not already open, and open the project file if it was saved in 

Test 1.  Add helotes_dem, if it is not in the Project View.  Double-click on helotes_dem 
to open the Legend Editor.  Change the number of classes to 12, and select Elevation 
#1 from the Color Ramp dropdown menu.  Click Apply.  The classification bins are now 
represented by unique colors from cyan as the lowest elevation to white as the highest 
elevation to mimic surface topology (Figure 12). 
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Figure 12.  Apply Elevation Color Ramp to Elevation DEM 
 

● Click File > Extensions > Spatial Analyst and check the box, if unchecked. 

● Use Spatial Analyst to obtain the Aspect of a DEM. 

− With helotes_dem still active, click Surface > Derive Aspect.  ArcView GIS 
automatically adds the new grid to the Project View.  The legend represents 
the degree of the steepest downhill slope direction from each cell to its 
neighbor.  The slope direction is classified by quarter directional degree 
intervals (N, NE, E, etc.) (Figure 13a). 

 

Figure 13a.  Aspect of Helotes DEM 



35 

 
● Aspect_of_Helotes_dem was saved to the data_gis_validation directory and is 

temporary; it is totally dependent on the helotes_dem.  When the helotes_dem is 
deleted, the Aspect grid will be deleted.  Look in the data_gis_validation directory 
or look at Theme > Properties to see the Source (Figure 13b). 

 

 

Figure 13b.  Theme Source in Theme Properties 

 
● This grid was saved as Aspect1.  If this grid needs to be permanent, it will need to 

be saved as a grid at Theme > Convert to Grid (Figure 13c). 
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Figure 13c.  Convert to Grid 

 
● Grid data can be queried using the Map Query Dialog, as well as making 

calculations using the Map Calculator. 
− Click aspect_of_Helotes_dem to make it active.  Click Analysis > Map Query 

to open Map Query Dialog Builder.  Enter 
“([aspect_of_Helotes_dem])>=107.126AsGrid” in the dialog box by using the 
available choices in the menu boxes.  “AsGrid” is added automatically.  The 
resulting grid is temporary and dependent on aspect_of_Helotes_dem.  If 
aspect_of_Helotes_dem is deleted from the Project, Query1 grid will be 
deleted from the data_gis_validation directory.  Query1 grid, value >=107.126, 
has three classification bins:  True, False, and No Data.  To better display the 
information, change the True color to blue using the Legend Editor.  The red, 
orange, and yellow areas are showing through from the 
aspect_of_Helotes_dem that is equal to the False statement of the Query.  
Check the values in aspect_of_Helotes_dem to confirm the query results.  The 
East direction represented by yellow shows values larger than or equal to 
107.126; values less than 107.126 are in the True category of the Query 
(Figure 13d). 
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Figure 13d.  Query Aspect Grid 

 
− Uncheck the TOC boxes for Map Query1 and aspect_of_Helotes_dem to 

make them invisible. 

● Calculate the maximum rate of change from each cell to its neighbor by using the 
Slope function. 

− Click on helotes_dem to make it active. 

− Select Surface > Derive Slope.  ArcView GIS automatically creates a new grid 
saved in the data_gis_validation directory; the classification bins represent 
degree of slope.  Use the Legend Editor to change the color ramp if it is 
difficult to distinguish the classifications (Figure 14). 
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Figure 14.  Slope of Helotes DEM 

 
(2) Create a Hillshade or Shaded Relief to give depth to helotes_dem.  The Hillshade 

represents the hypothetical illumination of a surface that can be used for analysis or as a 
background display. 

 
● Remove the check mark from Slope_of_Helotes_dem.  Click the helotes_dem in 

the TOC to make it active. 

● In the Surface menu, click Compute Hillshade.  Surface > Compute Hillshade.  
The Compute Hillshade window opens so the azimuth of the light source direction 
and the degree of altitude above the light source horizon can be selected.  The 
light source is usually thought of as the sun.  Keep the default parameters and click 
OK.  The hillshade_of_Helotes_dem grid opens with a grayscale color ramp.  This 
grid is also a temporary file dependent on helotes_dem grid. 

● Make the hillshade visible by checking its box.  The grid becomes a representation 
of the surface having the sun coming from the northwest.  This is apparent from 
high areas being illuminated on the northwest-facing surface (#1 arrow, 
Figure 15a) with the shadow on the southeast side.  Illuminated areas of the lows 
are the northwest-facing surface of the southeast wall (#2 arrow, Figure 15a). 
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Figure 15a.  Hillshade 

 
● Click helotes_dem name in the TOC and drag it up the TOC until it is below 

slope_of_Helotes_dem.  With helotes_dem active, again select Surface > 
Compute Hillshade.  In the Compute Hillshade window, change azimuth to 20 
and click OK.  The second hillshade is added having the same name as the first 
hillshade; however, ArcView GIS has actually saved the grid as hlshd2.  This can 
be confirmed by checking Source in Theme > Properties (Figure 15b). 

 

#1 

#2
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Figure 15b.  Naming Convention of Duplicates by Grid Source 

 
● Compare the hillshades by turning the new hillshade on top on and off a few times.  

Make the new hillshade_of_Helotes_dem active, then select Edit > Delete 
Themes.  Click Yes to All to remove the grid from the project. 

● The hillshade grid can be used as brightness when combined with another grid 
used for color.  Both grids need to be of the same area and in the same projection. 

− Uncheck the hillshade_of_Helotes_dem box so it will not conceal the results of 
applying it to the helotes_dem grid.  Double-click the helotes_dem grid to open 
the Legend Editor.  Click on the Advanced button.  From the Advanced 
Options window, select hillshade_of_Helotes_dem as the Brightness Theme.  
The defaults for the Minimum and Maximum Cell Brightness are 20 and 80.  
Do not change the numbers and click OK.  Click Apply in the Legend Editor 
(Figure 15c). 
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Figure 15c.  Hillshade Used as Brightness Theme 

 
− Increasing the number for the Minimum Cell Brightness increases the 

brightness (no cell can have a brightness less than 20) without adding to the 
relief.  Decreasing the Maximum Cell Brightness number decreases the 
brightness.  The brightness settings help to enhance the surface relief and 
should be adjusted for the desired effects.  Reclick on Advanced in the 
Legend Editor, and change the Minimum and Maximum Cell Brightness to 
50.  Click OK and then click Apply in the Legend Editor (Figure 15d). 
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Figure 15d.  Cell Brightness Settings 

 
− Repeat the procedure changing the Minimum to 20 and the Maximum to 100 

(Figure 15e). 
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Figure 15e.  Increasing Maximum Brightness Value Increases Relief 
 

− Using a hillshade as a brightness theme is useful for analysis of surface 
features and can make some information easier to visualize.  Repeat the 
previous procedure, and apply hillshade_of_Helotes_dem as the brightness 
theme for slope_of_Helotes_dem using the default Cell Brightness settings 
(Figure 15f). 
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Figure 15f.  Brightness Theme Applied to Slope Grid 
 

− The areas with the highest degree of slope are much easier to identify.  While 
holding down the Shift Key, select slope_of_Helotes_dem, Query1, and 
aspect_of_Helotes_dem.  Delete from the Project View (Theme > Delete 
Themes > Yes to All). 

 
(3) Spatial Analyst can also create contour lines where the lines represent all contiguous 

values of the same height, magnitude, or whatever the grid values represent.  The function 
interpolates a line with the same magnitude, which rarely passes through the center of the 
cell.  The function also smoothes the lines, resulting in a realistic representation of the 
contour.  The output of the Contour function is a line theme. 

 
● Click on the Helotes_dem to make it active.  Click on Surface and on 

Create Contours.   

● In the Contour Parameter window, change the Contour Interval parameter to 50, 
leave the base contour at 0, and click OK. 

● ArcView GIS calculates the contours in 50-meter intervals and adds the new 
Shapefile theme.  The contour units will be the same as the z-value (in this case) 
units as the source grid. 

● Click on contours of Helotes_dem to make it active.  Use the Identify Tool, and 
select one of the contours to confirm the elevation is a multiple of 50 (Figure 16). 
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Figure 16.  Interpolation of Elevation Contours 

 
(4) A Vector theme can be created using a table in dBASE (.dbf), INFO, or Delimited Text 

(.txt) format containing x and y coordinates.  The new theme will continue its relationship 
to the table so that any changes made to the table are reflected in the theme.  This 
relationship may not be practicable when the table is the result of a query in a separate 
database and the connection to that database is not available.  Use Theme > Convert to 
Shapefile to create an independent theme to add to the project, and then the Event 
Theme created theme can be deleted from the Project. 

 
● Add the provided well location table to the project and create an Event Theme.  

With the View active, choose Properties from the View Menu.  Enter Meters as 
Map Units, if not set.  Click OK to close the View Properties window.  Make the 
Project window active.  Select Tables.  A list of the Attribute Tables worked with 
earlier is listed along with three option buttons at the top of the window.  Select 
Add.  The table is located in data_gis_validation\helotes_wells.  The table is in dbf 
format and will not be visible if the List Files of Type shows a different format.  
Select helotes_well_loc.dbf table and click OK.  The dBASE table opens and the 
name is added to the list of tables in the Project window. 

 
− Add the well location points to the View.  In the View Menu, select Add Event 

Theme.  The Event Theme dialog box opens.  Select helotes_well_loc.dbf 
from the Table dropdown list (Figure 17a). 
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Figure 17a.  Add Event Theme Source Table 

 
− In the X field, select East27 from the list and in the Y field, select North27 

(Figure 17b). 

 

 

Figure 17b.  Add Event Theme X and Y Coordinates Source Field 

 
− Click OK.  ArcView GIS created a point theme of the well locations.  Close the 

helotes_well_loc.dbf table.  Make the helotes_well_loc.dbf theme active.  Use 
the selection tool to select a well.  Reopen the dbf table by clicking on the 
Open Theme Table button.  The selected well location in the View is 
highlighted in the table.  Place the pointer tool over the well’s location point in 
the View.  The X and Y coordinates of the point are displayed in the upper 
right-hand corner of the ArcView GIS window.  The coordinates should be 
nearly the same as the record selected in the table (Figure 17c).   
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Figure 17c.  Verify Feature Location Using the Attribute Table 

 
● The scale of the View makes direct location very difficult.  Right click with the 

pointer in the View, and select Shape properties from the menu.  The selected 
location point is covered by a black marker point, and the Shape Properties box 
opens showing the type of feature and the location.  The edit options are not 
available, because the theme is not in Edit mode (Figure 17d).   
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Figure 17d.  Shape Properties Box 

 
● Select OK or Cancel, and the Shape Properties box and the marker point are 

deleted. 

● Make the helotes_well_loc.dbf theme active, if it is not already.  Click on the Select 
None button.  If the Shapefile is made with a selection made, only the selected 
features will be in the new shapefile.  Select Theme > Convert to Shapefile.  
ArcView GIS should have opened in the data_gis_validation directory.  Rename 
the file wells_loc.shp.  Select Yes in the Convert to Shapefile window to add the 
theme to the Project View. 

− Change the point color in the Color Palette to increase visibility, if needed.  
Delete the helotes_well_loc.dbf theme in the TOC.  Select Yes to All after 
Delete Themes in the Edit.  Close helotes_well_loc.dbf table.  Make the 
Project window active and select the table name.  Select Delete 
‘helotes_well_loc.dbf’ from the Project and Yes to All in the next window. 

 
(5) Create a grid from a point file, and then export the grid to an XYZ text file. 
 

● Select well_loc.shp in the TOC to make it active, if it is not already.  Open the 
Surface Menu; select Interpolate Grid.  In the Output Grid Specification 
window, change the Output Grid Extent to Same As well_loc.shp and Output 
Grid Cell Size to Same As helotes_dem.  The cell size should now read 30 m, 
431 rows, and 226 columns (Figure 18a).   
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Figure 18a.  Output Grid Specification Dialog Box 

 
● Click OK.  Leave the default selections in the Interpolate Surface window (make 

sure the Z-value Field is listed as elev_m) and click OK. 

● ArcView GIS adds the grid to the Project View.  Again, this is a temporary file, 
dependent on the well_loc.shp theme.  Click on well_loc.shp in the TOC, and drag 
it above the ‘Surface from well_loc.shp’ grid legend (Figure 18b). 

 

 

Figure 18b.  Convert Point Feature Theme to a Grid 

 
● With Surface from well_loc.shp active, select Theme > Convert to Grid.  Save 

the grid in the data_gis_validation direction as well_surface. 

● Export data from the grid to the XYZ text file.  Select File > Export Data Source > 
ASCII Raster in the Export File Type window.  In the Export Grids Window, 
select well_surface grid.  In the Export File: well_surface window, rename the 
grid well_grid_xyz.asc.  Select OK.  Verify the text file contains XYZ data from the 
well_surface grid by opening the asc file in Microsoft Notepad (Figure 18c). 
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Figure 18c.  Export Data Source to Convert Grid to Text File 

 
● The .asc format uses the cell size and the xy coordinates of the lower left corner to 

determine the spatial location.  The numbers listed are the elevations of the center 
point of the cell in meters.  This information corresponds to the information in the 
grid classifications.  This can be verified using the Identify tool on the 
well_surface grid. 

6.2.4 Expected Test Results 
ArcView GIS and the ArcView GIS Spatial Analyst Extension 2.0a will be used to create the 
following features: 

● An Aspect grid representing the steepest downslope direction from each cell to its 
neighbors will be created. 

● The Query Builder will be used to group a specified range of values, which should 
result in a new grid containing those values. 

● A Slope grid identifying the maximum rate of change from each cell to its 
neighbors will be created. 

● A Hillshade of the elevation grid will be made depicting the hypothetical 
illumination of the surface. 

● The Hillshade of an elevation grid will be used as a brightness theme to another 
grid having color resulting in giving the color grid depth or surface relief. 
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● The amount of surface relief will be controlled by adjusting the cell value of the 
minimum and maximum cell brightness. 

● An Elevation Contour Shapefile of contiguous values will be made at the 
specified contour interval. 

● A Table containing X and Y coordinates will be displayed in ArcView GIS as a 
dependent Event Theme.  The Event Theme will be converted to an 
independent Shapefile. 

● Location points will be verified by using the pointer, using the identify tool on the 
point, and opening the Shape Properties Box. 

● The point file will be used to make a Grid of elevations at a specified cell size and 
boundary limit. 

● The elevation grid of the point file will be converted to an ASCII text file having X, 
Y, and Z data. 

6.2.5 Test Results 
Spatial Analyst Extension 2.0a tools created an Aspect grid representing the steepest 
downslope direction from each cell to its neighbor and a Slope grid identifying the maximum 
rate of change from each cell to its neighbor from an ArcINFO elevation grid.  Hillshade created 
a shaded relief of the elevations depicting the hypothetical illumination of the surface.  The 
brightness theme was used to give depth or surface relief controlled by adjusting the cell value 
of the minimum and maximum cell brightness.  A Contour shapefile was created of contiguous 
elevation values at the specified interval.  An elevation grid was created from a point file 
containing elevations as a feature using the Interpolate Grid tool. 
 
ArcView created a point Event Theme from a spreadsheet containing x and y coordinates and 
then converted the event theme to a shapefile.  Grid data was exported to a text file format 
(ASCII) using the Export Data Source tool. 
 
 
 
Results verified by:  ___________________________  Date:  _____________ 
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