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1 SCOPE OF VALIDATION 

ERDAS IMAGINE@ developed by Leica Geosystems GIS and Mapping, LLC is a broad 
collection of software tools designed specifically to process airborne and satellite imagery. This 
software is an essential tool for image processing across a variety of disciplines under earth and 
planetary sciences. 

This Test Plan and Report will validate four selected techniques, specifically: 

0 File Management 

0 Mosaicking DOQ data 

0 Basic SAR Analysis 

0 Basic Multispectral Analysis 

Software validation of ERDAS IMAGINE should confirm that the software can correctly perform 
the above listed functions with the provided remote sensing data. 

2 REFERENCES 

0 

0 

ERDAS IMAGINE' Tour GuidesTM, 2003, PDF document 

ERDAS IMAGINE@ Field GuideTM, 2003, PDF document 

3 ENVIRONMENT 

3.1 Software 

0 Operating System: Microsoft@ Windows XP Professional, Version 2002, Service Pack 1 

3.2 Hardware 

0 Computer: Intel@ XeonTM 

0 CPU: 3.06GHz 

0 Memory: 2GBRAM 
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4 PREREQUISITES 

4.1 Setting Up the ERDAS IMAGINE Environment 

Start ERDAS IMAGINE 8.7. In the Select Viewer Type dialog, check the Don't ask me this 
question again and click the OK button. Examine the options on the screen (Figure 1). 

Figure 1. ERDAS IMAGINE Icon Panel 

Look for the drop down menu named Session in the upper left of the screen on the icon panel. 
Select the Preferences option. This opens the Preference Editor menu. The Preference Editor 
allows you to control and customize many IMAGINE parameters and default settings. With the 
User Interface & Session category open, change your Default Data Directory and Default 
Output Directory to the location of your ERDAS-IMAGINE-validation folders 
(i.e., d:\ERDAS-IMAGINE-validation data and d:\ERDAS-IMAGINE-validation output 
directories). Scroll down until you see the Delete Session Log on Exit and Delete History 
File on Exit. Click on both of these check boxes and make sure they are on. Change the 
Session Log Printing from Query to Never. Leave all other options in their default settings. 
Save the changes using the User Level option. Exit the Preference Editor by selecting Close. 

5 ASSUMPTIONS AND CONSTRAINTS 

None. 

6.1 File Management 

6.1 .I Objective 

6 TESTCASES 

Demonstrate that ERDAS IMAGINE can handle a variety of remotely sensed data formats. 
ERDAS IMAGINE should identify and read a large number of image formats including ERDAS 
IMAGINE (.img), GeoTlFF, JPEG, BMP, HDF, and MrSID. These are some of the most 
common used image formats at the CNWRA. 

6.1.2 Test Input 
Remote sensing datasets: IKONOS PAN/MSI data, product 72309, IR band, (IMG and MrSID) 
courtesy of spaceimaging.com; Landsat 4 TM WRS-2, Path 040, Row 034, band 4, June 29, 
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1989, (GeoTIFF, BMP, JPEG) courtesy of the University of Maryland - Global Land Cover 
Facility; ASTER data AST-L1 B SC:AST-LI B.003:2003286125 data (HDF) courtesy of NASA, 
GSFC, MITI, ERSDAC, JAROS and the U.S./Japan ASTER Science Team; ERS-1 SAR SLC 
radar.img, based on the ERS-1, SLCI, orbit-4051, track-399, date-240492 dataset, courtesy of 
ESA- EURIMAGE and Landsat TM germtm.img ERDAS IMAGINE test data. All datasets are 
available in the data directory supplied on CD. 

6.1.3 Test Procedure 
1. 

2. 

3. 

4. 

5. 

5. 

In the ERDAS IMAGINE 8.7 Viewer #I window, Select File > Open > Raster Layer. 

In the Select Layer to Add dialog three .img format datasets are shown: gremtm.img, 
nir-72309jan01 .img and radar.img. Select the germtm.img dataset. Click OK. The 
dataset will be loaded by default, as an RGB color, bands 4 (R), 3 (G), and 2 (B). Clicking 
the right mouse button > Fit Image to Window and the right mouse button > Fit Window 
to Image will allow visualization of the entire dataset in Viewer #I. Repeat this procedure 
for the other two .img datasets. These images will be loaded by default as Gray Scale 
images and displayed as black and white images. ERDAS default settings include a 
contrast stretch. 

Display the other image datasets by using a similar procedure as in Section 6.1.3, Part 3, 
by changing the Files of Type to MrSid, for visualizing the nir-72309jan01 .sid dataset; 
TIFF, for visualizing the landsat-p040r34-t890629-nn4.tif dataset); JFIF, for visualizing 
the landsat-p040r34-t890629.jpg dataset; and BMP, for visualizing the 
landsat-p040r34-t890629.bmp dataset. With the exception of MrSid dataset, all datasets 
will be displayed as RGB color. 

To display the ASTER dataset, click the Import button on the ERDAS IMAGINE Icon 
Panel. Select as Type ASTER EOS HDF Format and Media as File. Select pg- 
PRI B0000-2001062102~114~001 as the input file. This file is located in 
ERDAS-IMAGINE-validation data directory. For the output file select aster.img. Place 
this file in the ERDAS-IMAGINE-validation output directory. Click OK. Click the 
Correction ... button in the ASTER EOS HDF Format Importer. In the Correction 
Parameters dialog, check the Write Transform to Image box. Click the Radiometric 
Options tab. Click the Conversion to radiance button. Click OK and again click OK in 
the ASTER EOS HDF Format Importer. The Importing ASTER Data dialog will show the 
progress of importing four HDF layers into an .img file format. Close the dialog window 
and the ImportlExport window. 

Display the ASTER dataset. In the ERDAS IMAGINE 8.7 Viewer #I window, Select File > 
Open > Raster Layer. Change the directory to ERDAS-IMAGINE-validation output. In 
the Select Layer to Add dialog, select the aster.img dataset. Click the Raster Options 
tab and select Layer 3 for Red, Layer 2 for Green, and Layer 1 for Blue. Click OK. Right 
mouse click > Fit Image to Window and right mouse click > Fit Window to Image will 
allow visualization of the entire dataset in Viewer #I. Check to see if this dataset is 
georectified (Le., the information on the bottom part of Viewer # I  should be Geographic 
(Lat/Lon)/ WGS 84. 

Close Viewer #I 
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6.1.4 Test Results 
PASSIFAIL: The test is successful if all required results are obtained in Section 6.1.3. 

Tester: Deborah Waiting st Date: .$Z/ /O 5 
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6.2 Importing and Mosaicking USGS DEM Data 

6.2.1 Objective 
Demonstrate that ERDAS IMAGINE can correctly import USGS digital elevation models (DEM) 
data and mosaic two datasets into a single composite DEM. The output DEM will be visualized 
as a grey, pseudocolor, and relief image. 

6.2.2 Test Input 
Two data files named 2998270g.dem and the 2998280g.dem are used in this test. These files 
correspond to two adjacent 30 m DEMs (Le., Helotes and Castle Hills, Bexar County, TX). 
These files are provided by the Texas Natural Resources Information System (TNRIS) in USGS 
DEM format. The projection is Universal Transverse Mercator Projection (UTM), Zone 14N with 
North American Datum of 1983. Both files were previously extracted from Olympus DlSS and 
placed in the ERDAS-IMAGINE-validation Data directory. 

6.2.3 Test Procedure 
1. Import the DEM files into ERDAS IMAGINE. From the icon panel, select the Import 

function. In the ImporVExport dialog, set data type as USGS DEM and the Media as File. 
Select the 2998270g.dem as the input file and 2998270g.img as the output file. Make sure 
that the output file will reside inside of ERDAS-IMAGINE-validation output directory. 
Click OK. In the new dialog window (e.g., Import DEM data) check the image information 
(File Name: HELOTES, TX, Coord System UTM, Zone 14) and image extent (North- 
32771 14m, South-3263231, West-524203, East-536349). Click OK and then visualize 
the image. 

2. Redo the same steps as above for the 2998280g.dem. For this dataset the image 
information and extent should be: File Name: CASTLE HILLS, TX, Coord System UTM, 
Zone 14 and Image Extent: North-32771 59m, South-3263264, West-536304, East- 
548465. Close ImporVExport dialog. 

3. Select the Mosaic Images mosaicking function by selecting DataPrep > Mosaic Images 
from the ERDAS IMAGINE icon panel. The Mosaic Tool dialog appears. 

4. Select Edit > Add Images. Using the Shift key, select the two DEM files. Click OK. 

The two images will automatically be placed in their correct geographic locations within the 
Mosaic Tool window (Figure 2). 
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Figure 2. The ERDAS IMAGINE Mosaic Tool Dialog 

4. In the Mosaic Tool window, select Process > Run Mosaic. Enter mosaic-dem.img as 
the output file name and place it in the ERDAS-IMAGINE-validation output directory. 
Close the Mosaic Tool dialog (do not save changes before closing). 

5. Open a new Viewer and display mosaic-dem.img dataset (to display the dataset follow the 
instructions in Section 6.1.3, Part 3. Compare the output of the DEM mosaicking process 
with the output presented in Figure 3 and the file statistics shown in Figure 4. For 
visualizing file statistics, in Viewer # I  select Utility > Layerlnfo. 

I 

.02,3275662.24 (uTM/cMm lea) 

Figure 3. The mosaic-dem.img File 

6 



6. 

I I 

Figure 4. Statistics for the mosaic-dem.img File 

Visualize the mosaic data as a pseudocolor and relief image. 

a. Reopen the mosaic-dem.img image in Display #I. In the Select Layer to Add 
dialog select the mosaic-dem.img. Click the Raster Options tab and Display the 
image as Pseudo Color. Click OK. Resize the image to window and window to 
image using the right mouse and selecting Fit Image to Window and Fit Window to 
Image. From the Viewer #I pull down menu select Raster > Attributes. In the 
Raster Attribute Editor window select Edit > Colors. Use Blue as the Start Color 
and Red as the End Color. Change the Slice Type to By Equal Areas and then hit 
Apply. The result should be similar with the one presented in Figure 5. 
NOTE: When the DEM image is displayed as pseudocolor, the viewer could be 
black until attributes on the color table are changed. This is normal software 
behavior. 
Open a new Viewer by clicking the Viewer icon on the ERDAS IMAGINE 8.7 icon 
menu. Select mosaic-dem.img in the Select Layer to Add window. Click the Raster 
Options tab and Display the image as Relief. Click OK. Resize the image to 
window and window to image using the right mouse and selecting Fit Image to 
Window and Fit Window to Image. From the Viewer #2 pull down menu select 
Raster > Relief Shading Tool. In the Relief Tool window specify Azimuth as 230 
degrees, sun elevation as 40 and the scale 3. Then click Apply. The result should 
be similar with the one presented in Figure 6. 

b. 
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Viewer #1 : niosaic-dern.img (:Layer 1 )  

,,, 

Figure 5. DEM - Pseudocolor Scheme 

- 
Figure 6. DEM - Digital Relief 

7. 

6.2.4 Test Results 
PASSIFAIL: The test is successful if all required results are obtained in Section 6.2.3. 

Close the lmagelnfo dialog, Viewer #I, and Viewer #2. 

Tester: Deborah Waiting Test Date: 

8 



W 

6.3 Basic SAR Analysis 
Radar remote sensing has a number of advantages over the optical remote sensing, because it 
allows obtaining data virtually under any time and condition. Because radar and optical systems 
operate in different parts of the electromagnetic spectrum (e.g., optical systems operate in the 
0.4-12 um and radar in the 0.8-100 cm range), the inferred characteristics of the surface 
materials have no direct relationship one to another. However, this complementarity is mostly 
beneficial in providing additional insights about the nature of surface materials. One of the most 
used radar remote sensing data types is the Synthetic Aperture Radar (SAR) data, subject of 
this test. SAR proved to be essential to a large variety of applications starting with geology and 
agriculture to ocean and sea ice. Recently, by exploring phase information on pairs of SAR 
data, ground subsidence could be measured with centimeter or even millimeter accuracy. 
These techniques (i.e., radar interferometry techniques) open the possibility of using SAR data 
in other areas, such as earthquake or subsidence monitoring (like the ones caused by mining 
activities, tunneling, or fluid dynamics). 

6.3.1 Objective 
Demonstrate that ERDAS IMAGINE can correctly perform basic single-band SAR data analysis. 
The following components will be tested: 

0 

0 Contrast Stretching, Adaptive Filters 

0 Speckle Reduction 

0 Density Slicing 

Display ERS SAR SLC data 

6.3.2 Test Input 
Data used for the test (e.g., radarhg)  is an ERS-1 Synthetic Aperture Radar Single Look 
Complex (ERS-1 SAR SLC) dataset, previously resampled (factor 5 on y axis) and converted to 
ERDAS IMAGINE format. The dataset provided by ESA-Eurimage, was acquired on April 24, 
1992 over the Barstow, California area, This dataset contains two bands: band one 
corresponds to the magnitude and band two to the phase of the retrieved radar signal. 

The file is located in the ERDAS-IMAGINE-validation Data directory. 

6.3.3 Test Procedure 
1. Read and display ERS-1 Single Look Complex (SLC) Data. 

a. ERDAS IMAGINE should be running and a Viewer should be open. Open the data 
files by selecting File > Open > Raster Layer. In the Select Layer to Add dialog, 
choose the radar.img file then load it as a Gray Scale image. 
Visualize the magnitude and phase information. The current viewer (e.g., Viewer #I )  
displays the magnitude of the signal. Open a second viewer. Load the second band 
of the radar.img dataset by clicking the Raster Options tab, selecting the Display as 
Gray Scale and Layer 2. Click OK. Fit the Image to Window and Fit Window to 
Image using a procedure similar to that in Section 6.1.3, Part 3. 
Compare the results with the ones shown in Figure 7. 

b. 

c. 
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Figure 7. The Magnitude and Phase of the ERS-1 SLC Dataset 

2. Remove radar speckle using the Frost adaptive filter. 

One of the problems associated with Radar data is the presence of noise. The noise is inherent 
in a SAR system due to the coherent nature of the radar signal. In this test, a Frost filter is used 
to reduce speckle while preserving the edges in the data. The filter replaces the initial value of 
a pixel, a value calculated based on the distance from the filter center, and the local variance. 
To apply the Frost Filter on the ERS-1 image follow the directions below. 

a. From the icon panel, select Radar > Radar Interpreter > Speckle Suppression. In 
the Radar Speckle Suppression dialog choose radar.img as the input image, and 
Frost as the Filter to use. Use a Moving Window, size of 3, and use the default 
Coef. of Variation (e.g., 0.2). Place the output file (e.g., radar-frost.img) in the 
ERDAS-IMAGINE-validation output directory. Click OK. 
Close all the windows so the only windows on the screen are the ERDAS IMAGINE 
icon panel and Viewers # I  and #2. In Viewer #2 open the newly created file 
(e.g., radar-frost.img). Compare the two images by Geographical linking both 
windows by selecting the LinWUnlink Viewers under Viewer's # I  View pull down 
menu (Figure 8). Select the Inquire Cursor function under the Utility pull down 
menu. Compare the magnitude values (PIXEL VALUE in each of the images) 
obtained at the same X,Y location. These values should be in the same order of 
magnitude. Note the reduced level of the "salt and pepper" noise on the filtered 
image. Close all the windows so the only windows on the screen are the ERDAS 
IMAGINE icon panel and Viewer #2. 

b. 
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Figure 8. Comparison between the Unfiltered and Filtered ERS-1 SAR SLC Image. Left 
Is the Original Image. Right Is After Applying a Frost Filter, 3x3 Window Size with a 

Coefficient of Variation Equal to 0.2. 

3. Density Slice. 

This technique allows visualization of radar differences using a colormap constructed based on 
a priori assignment of colors to image brightness intervals. The test will create a density sliced 
image with four levels, with higher radar backscatter values presented in the warmer colors. 

a. Re-open the Frost filtered ERS-1 data and display it as a Pseudo Color image 
(i.e., in the Select Layer to Add dialog select radar-frost.img, click Raster Options 
and display as Pseudo Color. Click OK. Fit Image to Window). 
Select Raster > Attributes. In the Raster Attribute Editor window select Edit > 
Colors. Select the Start Color as Blue and the End Color as Red. Set the number 
of levels to 5, Slice Type as By Equal Areas and the Slice Method as IHS Slice. 
Click the Apply button. 

b. 

c. Note the feature patterns and colors on the image and compare them with the ones 
shown in Figure 9. 
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Figure 9. Density Slice Technique Applied to the Filtered ERS-1 SAR SLC Image 

d. Close all the windows so the only window on the screen is the ERDAS IMAGINE 
icon panel. 

6.3.4 Test Results 
PASSIFAIL: The test is successful if all required results are obtained in Section 6.4.3. 

0 This test PASSED. 
r 

Tester: Deborah Waiting 
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6.4 Basic Multispectral Analysis 

6.4.1 Objective 
This test demonstrates ERDAS IMAGINE’S ability to perform a multispectral analysis. Results 
from an unsupervised (ISODATA) and supervised (parallelepiped) classification will be 
examined. 

6.4.2 Test Input 
Six band Landsat TM ERDAS IMAGINE dataset data acquired over Germantown, Maryland. 
This data is already converted from DN to reflectance values. The dataset (germtm.img) is part 
of the ERDAS IMAGINE tutorial data, and a copy of it was placed in the ERDAS 
IMAGINE-validation Data directory. 

6.4.3 Test Procedure 
1. Read and display Landsat TM Data. 

a. ERDAS IMAGINE should be running and Viewer #I should be open. Open the data 
files by selecting File > Open > Raster Layer. In the Select Layer to Add dialog, 
choose the germtm.img file then display it as a True Color image. Select Band 4 for 
the Red Channel, Band 3 for the Green Channel, and Band 2 for the Blue Channel 
(Figure IO.). 

Figure 10. Landsat TM Color Composite R4, G3, and 8 2  
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On this 4-, 3-, and 2-color composite image, bright red areas (which denote high infrared 
reflectance) correspond to healthy vegetation, along the rivers, or under cultivation. Forested 
areas are represented by a darker red color. Urban and bare soil areas are represented by 
turquoise or white. Water bodies have low reflectance values and are displayed in black. 

2. Performing an unsupervised classification. 

Unsupervised classification uses statistical techniques to group n-dimensional data into classes 
with similar characteristics. Knowledge of the terrain present in the scene, as well as its 
spectral characteristics, is needed to aposteori assigned information to the newly obtained 
classes. 

This test will perform an unsupervised classification using the Iterative Self-organizing Data 
Analysis Technique (IsoData) clustering algorithm. IsoData uses a minimum spectral distance 
formula to form spectrally distinct clusters. The algorithm repeats the clustering of the image 
until either a pre-defined maximum number of iterations, or a pre-defined maximum percentage 
of unchanged pixels have been reached between two consecutive iterations. 

a. From the ERDAS IMAGINE icon panel, select DataPrep > Unsupewised 
Classification. On the Unsupewised Classification (Isodata) dialog choose 
germtm.img as the Input Raster File. Set the Output File as germ-iso.img and 
place it in the Output directory. Choose 10 as the number of classes, maximum 
iterations as 20, and the convergence threshold as 0.950. Click OK to start the 
process. In the Job Status dialog, click OK when the process is 100% complete. 

Display the original and the output of the classification algorithm. In the same Viewer 
#I load the germjso.img by selecting File > Open > Raster Layer. Make sure that 
under the Raster Options tab the Clear Display checkbox is turned off. Click OK to 
display the image file. Right click the mouse button and select Fit Image to 
Window option. 
Perform a quick evaluation of the classification by using the Swipe function under 
the Utility pull-down menu. In the Viewer Swipe window drag the mouse to 
interactively change the Swipe position. Cancel the Swipe tool (Figure 11). 

b. 

c. 
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Figure 1 1. Data Visualization Using the Swipe Technique 

d. Assign individual colors for each class. Select Raster > Attributes. In the Raster 
Attribute Editor dialog, select Edit > Colors. Click Apply. Compare the ISODATA 
classification results with the one presented in Figure 12. 

Figure 11 displays a screen capture of how the swipe technique works. Fiaure 12 shows the 
result of classification (e.g., IsoData). After you cancel the swipe tool the ikage returns 
to 100%. 

15 
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Figure 12. IsoData Classification 

e. Close all ERDAS IMAGINE 8.7 Viewers. 

3. Performing a supervised classification. 

Compared with an unsupervised classification, such as the one performed in Section 6.4.3, 
Part 2a, supervised classification will require a priori selection of training areas used as the 
basis for classification. ERDAS IMAGINE provides a broad range of different traditional 
classification methods, such as the Minimum Distance, Parallelepiped or the Maximum 
Likelihood. 
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The test will evaluate the Maximum Likelihood method using as training sites, a list of previously 
defined spectral signatures extracted from the major land cover classes of the area. These 
signatures reside in the germtmsig file. 

a. ERDAS IMAGINE should be running and a Viewer should be open. Open the data 
files by selecting File > Open > Raster Layer. In the Select Layer to Add dialog, 
choose the germtm.img file then display it as a True Color image. Select Band 4 for 
the Red Channel, Band 3 for the Green Channel, and Band 2 for the Blue Channel. 
From the ERDAS IMAGINE icon panel, select Classifier > Signature Editor. In the 
Signature Editor dialog choose File > Open and load the germtmsig from the 
ERDAS IMAGINE-validation Data directory. Make sure that the function to be 
performed in the Load Signature File directory is set to Replace. The signature file 
assumes that the associated germtm.img is located on D:/erdas-imagine validation. 
If the data directory is placed in a different location, the file association needs to be 
updated. To do this click OK in the Message pop-up window. Select Edit from the 
Signature Editor pull-down menu. Click OK in the Error and Messages pop-up 
windows. Click Edit again and select Image Association. Set the associated 
image to the current location of the data directory. Click OK. The table shows the 
previously defined signatures and their associated names for the land cover classes. 
From the ERDAS IMAGINE icon panel, select Classification > Supervised 
Classification. Select germtm.img as the Input Raster File and the germtmsig as 
the Input Signature File. Set the Classified File as germ-supervised.img and place 
it in the Output directory. Check the Distance File button and set the filename as 
germtm-distance.img. This distance file is a continuous layer in which each pixel 
value represents the result of a spectral distance measure used in the performed 
supervised classification. Brighter pixels (e.g., higher distance values) represent 
pixels more likely to be misclassed. Run the classifier. 
Examine the result of the classification and compare it with the one shown in 
Figure 13. Note if pattern differences exist between the supervised images. 

b. 

c. 

d. 
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Figure 13. The Result of the Maximum Likelihood Classifier on the Left and 
the Distance Image on the Right 

6.4.4 Test Results 
PASS/FAIL: The test is successful if all required results are obtained in Section 6.4.3. 

0 This test PASSED. 

Tester: Deborah Waiting / L / / o A Y  

7 CONCLUSION 

[he ERDAS IMAGINE, Version 8.7, has completed all tested features successfully. 
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