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1 SCOPE OF VALIDATION 

ENVl@ (the Environment for Visualizing Images) developed by Research Systems, Inc. (RSI), is 
an image processing software for visualization, exploration, analysis, and presentation of 
airborne and satellite remotely sensed images. The software has flexibility to design and 
implement any particular analysis strategies being an essential tool for image processing across 
a variety of disciplines. 

This Test Plan and Report will validate four selected techniques, specifically: 

0 File Management 
0 Mosaicking DOQ Data 
0 Basic SAR Analysis 
0 Basic Multispectral Analysis using Multispectral and Hyperspectral Tools 

Software validation of ENVl@ should confirm that the software can correctly perform the above 
listed functions with original or RSI provided remote sensing data. 

2 REFERENCES 

ENVl, The Complete Remote Sensing Package, httD://www.rsinc.com/envi/index.asD. 

ENVl User's Guide, ENVl Version 4.1, September 2004 Edition, PDF document. 

ENVl Tutorials, September 2004 Edition, PDF document. 

3 ENVIRONMENT 

3.1 Software 

0 System: Microsoft@ Windows XP Professional 

3.2 Hardware 

0 Computer: Intel@ Pentium 4 
0 CPU2.8GHz 
0 Memory: 496MBRAM 
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4 PREREQUISITES 

None. 

None. 

5 ASSUMPTIONS AND CONSTRAINTS 

6 TESTCASES 

6.1 File Management 

6.1 . I  Objective 
Demonstrate that ENVl@ can handle a variety of satellite image formats. ENVI should identify 
and read a large number of image formats including GeoTIFF, JPEG, BMP, HDF, BSQ, ERDAS 
Imagine (.img) and MrSID. Those are the most common used image formats at the CNWRA. 

6.1.2 Test Input 
Remote sensing datasets: IKONOS PAN/MSI data, product 72309, IR band, (IMG and MrSID) 
courtesy of spaceimaging.com; Landsat 4 TM WRS-2, Path 040, Row 034, band 4, June 29, 
1989, (GeoTIFF, BMP, JPEG) courtesy of the University of Maryland-Global Land Cover 
Facility; ASTER data AST-L1 B SC:AST-LI B.003:2003286125 data (HDF) courtesy of NASA, 
GSFC, MITI, ERSDAC, JAROS and the U.S./Japan ASTER Science Team; and RSl’s 
RADARSAT bonnrsat.img (BSQ) and RSl’s Landsat TM can-tmr.img (BSQ) test data. All 
images with the exception of ILONOS data are available in the data directory. 

6.1.3 Test Procedure 
1. Open ENVI 4.1 and Select File > Open Image File. 

2. When the Enter Data Filenames dialog appears, change the browsing location to 
ENVl-validation Data directory and select each individual file available for testing (use 
SHIFT button to select all datasets at once or CTRL button for individual selection). 
Those files are: bonnrsat.img, can-tmr.img, landsat-p040r34-t890629.bmp, 
landsat-p040r34-t890629.jpg, landsat-p040r34-t890629-nn4.tif, nir-72309jan01 .img, 
nir-72309-jan01 Ad, pg-PRI BOOOO-2001062102~114~001. Select Open. ENVl 
automatically extracts the header information and enters the image bands into the 
Available Bands List Window. Resize the Available Bands List Window to see the 
content of each dataset. Please note the variability in the number of bands (e.g., one 
band for bonnrsat.img, landsat-p040r34-t890629-nn4.tif, nir-72309Jan01 .img, - 
PRI B0000-2001062102~114~001 versus multiband datasets for the rest of the files) 
spatial sizes (ASTER data has two spatial sizes which are packaged as two separated 
datasets) and geo-information (the .jpg, .bmp, can-tmr.img and bonnrsat.img datasets 
are not georeferenced, the rest have UTM, Zone 1 1 N projection). 

3. Load each monoband dataset as a Gray Scale image and multiband images as 
RGB Color images. Do this by using the following steps. 
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a. For a monoband dataset: Click the Grey Scale button. Select the band inside 
the dataset. For example, select Band-I for the nir-72309Jan01 .img. Click 
Load Band button. Repeat the step for the next multi-band dataset. 

b. For a multiband dataset: Click the RGB Color button. Pair any three dataset 
bands to the RGB guns. For example, to display a Landsat TM RGB color 
composite using bands 3,2,1, click R and then click the TM Band1 (0.4850); G 
and then TM Band 2 (0.5600); and B and TM Band 3 (0.6600). Click Load RGB 
button. Repeat the step for the next multiband dataset. 

4. Close all opened datasets by selecting Close All Files option under File menu in 
Available Bands List dialog. 

6.1.4 Test Results 
PASSIFAIL: The test is successful if all required results are obtained in Section 6.1.3. 

This test PASSED. The following comments substantiate the PASSING grade. 

0 

0 

ENVl correctly displayed original geospatial datasets. Problems could exist if the Header 
Info Dialog is displayed, instead of the Available Bands List window. 
The GeoTIFF, HDF and ERDAS Imagine and MrSlD files had correctly displayed the 
geographic information (all these datasets have a UTM projection, and Zone 1 1 N). 

Tester: Debora Waiting -Test Date: 
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6.2 Mosaicking DOQ Data 

6.2.1 Objective 
Demonstrate that ENVl can correctly (i) mosaic two digital orthophoto quarterquads (DOQ) 
datasets into a single composite image and (ii) resample data to a different pixel size. The 
correctness of mosaic's registration will be checked against ESRI@ Texas roads dataset. 

6.2.2 Test Input 
Two data files named 2998282b.tif and 2998281 b.tif are used in this test. Those files 
correspond to two adjacent DOQs (i.e., the East and West Castle Hills quads, 2998 block 
degree, Bexar County, TX). Each DOQ is a 2.5-meter ground resolution, quarter-quadrangle 
(3.75-minutes of latitude by 3.75-minutes of longitude) image. These files are provided in a 
Universal Transverse Mercator Projection (UTM) with North American Datum of 1983. The 
geographic extent of each DOQ is equivalent to a quarter-quad plus approximately 300 meters 
margin area. Both files (2998281 b.tif and 2998282b.tiff) were previously downloaded and 
placed in the ENVl-validation Data directory. The Data directory contains also the ESRl Texas 
major roads vector dataset component of the 2000 ESRl Data & Maps CD, previously re- 
projected from Geographic Coordinates to UTM Zone 14. 

6.2.3 Test Procedure 
1. Open the test data files by selecting File > Open Image File option in the Available 

Bands List dialog window. Select the 2998282b.tif file then hold down the Shift key and 
select the 299821 b.tif file. 

2. Select the Georeferenced mosaicking function by selecting Basic Tools > Mosaicking 
> Georeferenced from the ENVl main menu. The Map Based Mosaic dialog appears. 

3. Select Import > Import Files. Using the Shift key, select the two available files. 
Click OK. 

The two images will automatically be placed in their correct geographic locations within the 
Mosaic Preview display. In this display, the images have independent 2% contrast stretches 
applied by default. 
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0 

Mosaic 5101 x 3038 CUTM. 21 

~~ 

Figure 1. The Mosaic Dialog 

5. Notice the contrast between the two images (e.g., the 2998281 b.tif image with the green 
outline is slightly darker than the 2998282b.tif image with the red outline). With ENVI, 
color balancing can be performed by doing the following: 

a. In the Mosaic dialog, right click on the 2998281 b.tif filename and choose 
Edit Entry. 

b. Select Adjust on the Color Balancing to define this dataset as the one for which 
the contrast adjustment will be performed. Choose OK. 

c. Right click on the name of the 2998282b.tif file, and choose Edit Entry. In the 
resulting dialog, under Color Balancing, choose Fixed. This indicates that the 
contrast of this image will not be changed. Choose OK. 

d. 
e. 

From the Mosaic dialog choose File > Apply. 
In the resulting Mosaic Parameters dialog, there is now a Color Balance using 
option near the bottom. Leave this value at stats from overlapping regions. 
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6. Use the Choose button to locate the ENVl validation Output directory. Enter mosaic.img 
as the name for the output filename. Set 5.00 m as the new values for the Output X and 
Output Y pixel sizes. Choose OK. The resulting mosaic will be entered into the 
Available Bands List when it is finished. 

7. Display the new mosaic in an RGB display with Mosaic (Band 1) as red, Mosaic 
(Band 2) as green, and Mosaic (Band 3) as blue. Note that the contrast between the two 
images is much less visible (Figure 2). 

Figure 2. The Result of the Mosaicking Process 

8. From the Image Menu select Overlay > Vectors. In the Vector Parameters: Cursor 
Query dialog click File > Open Vector File. Change the File of type to Shapefile 
(*.shp). Navigate to ENVl-validation Data directory, and select the txrds.shp file. Click 
Open. In the Import Vector Files Parameters, click the OK button. The roads will be 
loaded and displayed in white over the DOQ mosaic. To change the color, select Edit > 
Edit Layer Properties in the Vector Parameters: Cursor Query dialog. Right click the 
Color button. From Items 1:20 select color Green. Click OK in the Edit Vector Layers 
window. 

9. Visualize the overlay between the vector layer and the DOQ mosaic image. 

I O .  Close all open datasets by selecting Close All Files option under File menu in Available 
Bands List dialog. 
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6.2.4 Test Results 
PASSIFAIL: The test is successful if all required results are obtained in Section 6.2.3. 

This test PASSED. The following comments substantiate the PASSING grade. 

0 ENVl correctly mosaicked the DOQ images. The contrast between the two DOQ datasets 
almost disappeared when the color balancing technique was used. 

0 ENVl correctly overlaid the road data on top of the DOQ mosaic image. The eventual 
misalignments were expected because the ESRl dataset has a much coarser accuracy 
compared to the pixel size of the DOQ images (Le., the ESRl dataset meets the National 
Map Accuracy standards of +/- 167 feet). 

Tester: Deborah Waiting 
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6.3 Basic SAR Analysis 

Radar remote sensing has a number of advantages over the optical remote sensing because it 
allows obtaining data virtually under any time and conditions. Because radar and optical 
systems operate in different parts of the electromagnetic spectrum (e.g., optical systems 
operate in the 0.4-1 2 um and radar in the 0.8-1 00 cm range), the inferred characteristics of the 
surface materials have no direct relationship one to another. However, this complementarity is 
mostly beneficial providing additional insights about the nature of surface materials. One of the 
most used radar remote sensing data types is the Synthetic Aperture Radar (SAR) data, subject 
of this test. SAR proved to be essential in a large variety of applications from geology and 
agriculture to ocean and sea ice. Recently, by exploring phase information on pairs of SAR 
data, ground subsidence could be measured with centimeter or even millimeter accuracy. 
Those techniques (i.e., radar interferometry techniques) open the possibility of using SAR data 
in other areas, such as earthquake or subsidence monitoring (like the ones caused by mining 
activities, tunneling, or fluid dynamics). 

6.3.1 Objective 
Demonstrate that ENVl can correctly perform basic single-band SAR data analysis. The 
following components will be tested: 

0 

0 Ingest Verification 
0 Contrast Stretching, Adaptive Filters 
0 Speckle Reduction 
0 Density Slicing 

Browsing the SAR Data Header Information 

This test is using the steps described in the “Multispectral Classification” section of the ENVl 
Tutorials handbook. 

6.3.2 Test Input 
Data used for the test is a subset of a RADARSAT 1 Path Image, Fine Beam 2, December 17, 
1995, Bonn, Germany. This image (e.g. bonnrsathg ) is part of the ENVl test dataset. For 
convenience, a copy of it was placed in the ENVl-validation Data directory 

6.3.3 Test Procedure 
1. Read and display SAR header data. The information listed in the header file is needed 

for the situations when in-depth InSAR processing is performed. 

a. Open the data files by selecting File > Open Image File. Select the bonnrsat.img 
then load it as a Gray Scale image (see Paragraph 6.1.3). To enhance the image 
(use the Enhance option on the ENVl pull-down menu) apply different stretching 
techniques such as Equalization and Square Root. Note the changes in the 
brightness characteristics of the image. 
Select Radar > OpenlPrepare Radar File. Select View Radarsat Header and 
open the bonnrsat.001 file. The header information displayed in the CEOS Header 
Report window should be similar to the one shown in Figure 3. 

b. 
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c. Close the CEOS Header Report window. 

Figure 3. RADARSAT Header Information 
2. Remove the noise (speckle) in ERS data using the Frost adaptive filter. 

One of the problems associated with radar data is the presence of noise. The noise is inherent 
in a SAR system, due to the coherent nature of the radar signal. In this test, a Frost filter is 
used to reduce speckle while preserving the edges in the data. The filter replaces the initial 
value of a pixel, which is a value calculated based on the distance from the filter center, local 
variance, and the dampling factor. Steps to apply the Frost filter to the RADARSAT 
image follow. 
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a. 

b. 

C. 

d. 

Apply a 2% stretch to the image displayed in Display number 1. Use Enhance > 
[Scroll] Linear 2%. 
On the Available Bands List dialog, click Display number 1 , then New Display. 
A new empty display is created. Minimize the Available Bands List dialog. 
Select Radar > Adaptive Filters > Frost. Choose bonnrsat.img as the input 
image and use the default 3x3 filter size with a Damping factor of 1. Enter an 
output filename in the ENVl validation Output directory and click OK. Load the 
newly created file in Display number 2. 
Select Tools > Link > Link Displays to link the Frost filtered image with the 2% 
linear stretch image shown Display number 1. In the Link Displays dialog, click 
the OK button. Click the left mouse button in any linked window to visualize the 
effect of the adaptive filter. 

Figure 4. RADARSAT Image. Left 2% Stretch Image. Right After Applying a Frost Filter, 
3x3 Window Size with a Dampling Factor of 1. 

3. Density Slice. 

This technique allows visualization of radar differences using a colormap constructed based on 
a priori assignment of colors to image brightness intervals. The test will create a density sliced 
image with four levels, with higher radar backscatter values presented in the warmer colors. 

a. 

b. 

In the Frost Filtered image display, choose Tools > Color Mapping > Density 
Slice. Click OK. 
In the newly created window, the number of default ranges is 8. Change it 
(Options > Set Number of Default Ranges) to a different number and then click 
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a 

Clear Ranges. Calculate the new density slice ranges (Options > Apply Default 
Ranges) and click the Apply button. 
Display the radar image using a pre-defined range scheme. From the Density 
Slice window choose File > Restore Ranges and select the dslice.dsr file. Click 
Open. Four slice ranges should show in the Defined Density Slice Ranges. 
Click Apply in the Density Slice dialog to update the image. 

c. 

d. Note the feature patterns and colors on the image and compare them with 
Figure 5. 

Figure 5. Density Slice Technique Applied to the RADARSAT Image 

4. Close all opened datasets by selecting Close All Files option under File menu in 
Available Bands List dialog. 

6.3.4 Test Results 
PASSIFAIL: The test is successful if all required results are obtained in Section 6.4.3. 

This test PASSED. 

Tester: Deborah Waiting est Date: 3 
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6.4 Basic Multispectral Analysis using Multispectral and Hyperspectral 
Tools 

6.4.1 Objective 
This test demonstrates ENVl’s ability to perform a multispectral analysis. Results from an 
unsupervised (IsoData) and supervised (parallelepiped) classification will be first examined. 
Finally, the test will evaluate the accuracy of classification by comparing it with the one 
generated by RSI. 

This test is based on the “Multispectral Classification” section of the ENVl Tutorials handbook. 

6.4.2 Test Input 
Landsat Thematic Mapper (TM), ENVl test data from Canyon City, Colorado contained in the file 
can-tmr.img. This data is already converted from digital numbers (DN) to reflectance values. 
The dataset is part of the ENVl tutorial data, and a copy of it is conveniently placed in the 
ENVl-validation Data directory. 

6.4.3 Test Procedure 
1. Read and display Landsat TM Data. 

Start ENVI. Open the data files by selecting File > Open Image File. Select the can-tmr.img 
file. Click sequentially on bands 4, 3, and 2. Click on the Load RGB button to load the image. 

Figure 6. Landsat TM Color Composite R4, G3, B2 
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On a 4, 3, and 2 color-composite, bright red areas (which denote high infrared reflectance) 
correspond to healthy vegetation, along the rivers or under cultivation. In this image dataset, 
darker red areas correspond mainly to coniferous trees. 

2. Performing an unsupervised classification 

Unsupervised classification uses statistical techniques to group n-dimensional data into classes 
with similar characteristics. Knowledge of the terrain present in the scene, as well as its 
spectral characteristics, is needed to assign information to the newly obtained classes. 

This test will perform an unsupervised classification using the Iterative Self-organizing Data 
Analysis Technique (IsoData) clustering algorithm. IsoData uses a minimum spectral distance 
formula to form spectrally distinct clusters. The algorithm repeats the clustering of the image 
until either a pre-defined maximum number of iterations or a pre-defined maximum percentage 
of unchanged pixels have been reached between two consecutive iterations. 

a. From the ENVl pull down menu, select Classification > Unsupervised > IsoData. 
On the Classification Input File Dialog choose the can-tmr.img file. Click OK. 
For the IsoData parameters use all of the default values. Select Memory for the 
Output Result and then click OK. 
Open the Memory1 dataset in the available band list and choose New Display on 
the pull-down menu. Then click on the Load Band button. 
Select Tools > Link > Link Displays. Click OK to link the IsoData classification 
with the color composite image. 
Compare the new classification to the color composite image. First, in the IsoData 
window, define an area of visualization by clicking and dragging a rectangle using 
the middle mouse button. Then, using the left mouse button move the newly 
created window over the entire classification image. Note the association between 
the features identified in the color image and the IsoData classes (Figure 7). 
Close all opened datasets by selecting Close All Files option under the File menu 
in Available Bands List dialog. 

b. 

c. 

d. 

e. 
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Figure 7. IsoData Classification 

3. Performing a supervised classification. 

Compared with an unsupervised classification, such as the one performed in 
Section 6.4.3, Number 2a, a supervised classification requires a priori selection of 
training areas. ENVI provides a broad range of traditional classification methods, 
including Minimum Distance, Parallelepiped, or Maximum Likelihood. 

The test will use the Parallelepiped method as training areas, several predefined 
regions of interest (ROI). This method uses a simple decision rule to classify multispectral 
data. Based on this rule, the standard deviation threshold and the mean value of each selected 
ROI is used to define the decision boundaries of an n-dimensional parallelepiped in the image 
data space 

Because the supervised classification requires knowledge of the area, this test will use training 
sites previously defined by RSI. 

a. From the Available Bands List select the can-tmr.img dataset and load it as an 
RGB color imagine (Bands 4, 3, 2). See Section 6.1.3 for loading instructions for 
an RGB color image. 
Restore ROI. From the Image Viewer menu bar, select Overlay > Region of 
Interest. In the #I ROI Tool dialog choose File > Restore ROls. The Enter ROI 
Filename dialog opens. Select CLASSES.ROI as the input file to restore. Click 
Open. In the ENVl Message window, note three regions that were restored. Click 
OK. In the #I ROI Tool, delete the first record showing 0 Pixels and 010 Polygons. 

b. 

14 



C. 

d. 

Select the record by clicking the tab left of the Region #I ROI and then click 
Delete, Select All records. 
From the ENVl main menu, select Classification > Supervised > Parallelepiped. 
Select the can-tmr.img dataset. Click OK. In the newly opened Parallelepiped 
Parameters dialog, Select All Items from defined regions and set the Output 
Result to can-pclass.img. Leave Output Rule Images unchanged. Confirm that 
the output directory is ENVl validation Output directory. Leave the Max stdev 
from Mean on 3.00 (single value). Click OK. 
Examine the result of the classification and compare it with the one obtained by 
RSI (Figure 4-3, Tutorial Guide). Figure 8 shows one similar to the RSI result. 
Note if any pattern differences exist between these two results. 

1----1 - 1  1 
I ,  

Figure 8. RSl's Parallelepiped Classification 

4. Performing a supervised classification using hyperspectral tools 

The following method employs tools that are generally used for analyzing hyperspectral data. 
Spectral Angle Mapper method is used to provide an alternative result for the classification 
created in Section 6.4.3, Number 3. First a set of spectras are collected from ROI. 

a. 

b. 

Start the Classification Input File dialog from the ENVl main menu by selecting 
Spectral > Mapping Methods > Endmember Collection. 
In the Classification Input File dialog, select as Input file the can-tmr.img dataset. 
Click OK. 
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c. Several classification methods can be used by choosing one of the 11 methods 
listed under Algorithm. For the purpose of this test, choose the Spectral Angle 
Mapper algorithm. 
Import the pre-defined ROls (Import > from ROllEVF from Input File > Select All 
Items > OK) and create regions #1-#3. Plot these regions and compare the 
spectras with the ones displayed in Figure 9. 

d. 

' OR 

80 

60 
d) 
IF - 
9 

40 

20 -.. --. - . -.. --- - 

Figure 9. SAM Endmember Collection and Spectra 

e. Click Apply. On the Spectral Angle Mapper Parameters Dialog enter the output 
filename can-sam.img (confirm that the output directory is ENVl Validation 
Output directory) and click OK. Compare the results with that shown in Figure I O .  
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Figure I O .  SAM Output 

5. Post Classification Processing 

To evaluate the accuracy of a classification method, a post-processing algorithm is required. 
This test will compare the classification results from Section 6.4.3, Numbers 3 and 4 by 
computing a confusion matrix. The SAM classification will be evaluated considering the output 
for the Parallelepiped method as the ground truth. Finally, the confusion matrix will be 
compared with the one generated by RSI. 

a. From the ENVl pull down menu, select Classification > Post Classification > 
Confusion Matrix > Using Ground Truth Image. Select can-sam.img as the 
input classification file. Click OK. Select can-pclass.img as the ground truth input 
file. Click OK. 
The corresponding classes are automatically matched in the Match Classes 
Parameters dialog window. Click OK. 

b. 

c. On the Confusion Matrix Parameters dialog, output result to Memory and click 
OK. Compare the Prod. ACC. and User Acc. results with the ones obtained by RSI 
(Figure 4-7, Tutorial Guide). Results similar to that of RSI are shown in Figure 11. 
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Figure 11. Confusion Matrix using the Output of the Parallelepiped 
Classifier as Ground Truth 

6.4.4 Test Results 

PASSIFAIL: The test is successful if all required results are obtained in Section 6.4.3. 

This test PASSED. 

Tester: Deborah Waiting st Date: 3 

7 CONCLUSION 

The ENVI, Version 4.1 software has completed all tested features successfully. 
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