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K The user may also build faults usinglne 3D Fault Viewer's Fault Builder teol, The user ray access 
the Fault ui ider by clicldng on ie BuWider Buttnh atthe top of the 3D Fault Viewer Window.

Upon pressing the Builder Button, the user will be presented with the Fault Builder Window.  
If a fault file is already loaded in the 3D Fault Viewer, the user may add to it. If no fault file is 
loaded, the user is presented with a default bounding box and may create a fault from scratch.  
The user should use the bounding box as a reference to the geographical coordinate system.  
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L

L

To add atrianl le to the 
fault, click the Start 
Trian le button. Anew 
triangle wei appear 
with vertices on the 
corners designated N, 
E, an d Up by the 
bounding box. To 
adjust any one of the 
vertices, hold dcvn the 
control key and select 
the vertex with the left 
mouse button while 
draging t he vert ex wit te m ouse.

The three buttons designated Affected Coordinates control the plane 
in vwIich the vertices are allowed to m ove. For example, to move a 
vertexalong the X-Yplane, selecithe X-Ybutton. X,Y and Z 
correspond to aright-handed coordinate system with +ZoComing out of 
the screen. Thus, ÷X runs horizontal from rtiht to left across the 
screen, and +Y runs Yeriicallyfrom top to bottm. This coordinate 
system is distinct and inde endent of the geographical coordinate 
system defined by the Ioaced fault and coverage files.

Points may be deleted and added to the triangle using the Delete Point and Add Point buttons, 
located directly below the triangle buttons. The current fault in progress may be aborted by 
clicking the Cancel button, located directly to the right of the End Triangle button. When 
finished, click the End Triangle button, located directly to the right of the Start triangle 
button. To remove all Fault-Builder produced polygons, click the Clear All button.  

Closing the window accepts modifications, but these mae not saved untill the user saves the 
file to disk via the 3D Fault Viewer's file pulldown menu.  
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The user should also note that coverages maybe placed over 3D objects. To 
access the coverage tool, the user should click on the Coverage Button located 
at the top of the 3ý Fault Viewer Window.
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Upon clicking the Coverage Button, the user is presented with the Coverage Tool.

To load a coverage file, click the Load button and a file selector will appear. After selecting a 
coverage file, the name of the file is displayed in the Viewer Coverage Tool. Each loaded 
coverage may be manipulated by clicking on the coverage name, then adjusting the color 
sliders or adjusting the Line Width slider. To remove a coverage select the name and click the 
Remove button.  

page 4 page 6
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An example of a coverage and a normal fault file loaded at the same time appears below.  
Note that the coverage is white and the normal fault file is shaded according to stress.

I1

while coverage
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Map Viewer 

The Map Viewer is used to display files of faults displayed as lines and overlay those images 
with coverages. To load a file, either choose Load from the File pull-down menu at the top of 
the Map Viewer window, or click on the Load button just below the File pull-down menu.

SFile Pull-Down Menu

U Load Button

A File Selection box will then appear prompting for the selection of a map. Use this dialog 
box to navigate the file-system and select the appropriate file as described in the Appendix.  

page2
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The Reset feature is used to reset the point-of-view in the Map Viewer window to the default, 
start-up location. Either select Reset from the File pull-down menu or click the Reset button 
just below the Window pull-down menu to reset the point-of-view.  

The Print feature is used to print the Map Viewer window to an SGI RGB file. Either select 
Print from the File pull-down menu or click the Print button just below the Window 
pull-down menu to access the Save File dialog box. Use this dialog box to navigate the 
file-system and select the apropriate filename to call the saved image.  
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The Options tool may be used to toggle display of the bounding box, toggle antialiasing, set 
line width, set the color scheme, set the dip direction, set the fault dip scale, and browse the 
data file. The Options tool may be accessed in a similar manner to the Load File dialog box.  
Either select Options from the File pull-down menu or click the Options button just below the 
Window pull-down menu. Upon loading a file, the filename will appear in the text box in the 
Options window. Multiple files may be loaded, and to remove one simply highlight the file 
and press the remove button below the text box. The files may also be saved as one lin file 
by pressing the Save File(s) button.

I1
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The Coverage tool is used to overlay a coverage image on top of the fault image. To access 
the coverage tool, either choose Coverage from the Window pull-down menu at the top of the 
Map Viewer window, or click on the Coverage button just below the pull-down menu bar.  
With the coverage, the user may load several files at once and toggle the displaying of each 
loaded file individually. Also, coverage depth may be set, the degree of magnification of the 
symbol data may be set. Symbols may be saved, and coverage files may be removed from the 
list. To load a coverage file, click on the Load button at the bottom of the Coverage Tool 
window. A dialog box will then appear prompting for the selection of a file. Use this dialog 
box to navigate the file-system and select the appropriate file.

A rose diagram is displayed by pressing the Rose button below the pull down menu bar or 
selecting Rose from the Window pull-down menu. See the Rose Diagram chapter for more 
information on the Rose Viewer.  

page 2 page4
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The Line-Building Tools dialog box may be used to place lines on existing maps. To begin a 
line, click the Start Line button. A new line will appear along the left edge of the bounding 
box with its end points at the comers. To select a point and move it, hold down the control 
key while clicking and dragging the point with the left mouse button. Points may also be 
added and deleted using the Add Point and Delete Point buttons. Added points always appear 
in the lower left comer of the bounding box. The point currently selected is the one deleted.  
A point may be selected by holding the control key and clicking the left mouse button over it.  
The selected point is displayed as yellow.

The user may remove all lines produced via the Line Builder by pressing the Clear All button.  
To exit the Map Viewer, select Close from the File pull-down menu or click the Close button 
below the pull-down menu bar. To access the online help for 3DStress, use the Help 
pull-down menu or click the Help button below the pull-down menu bar.
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Rose Diagram 

A rose diagram is displayed by pressing the Rose button on the map viewer. A rose diagram 
may only be displayed if a fault trace file or coverage is currently loaded.

page 2

C, oW 
10/30/00 10:32 AM



http://oso.geophysics.swri.edubwinlfrey/3dstressht.nmdocs/Rose Diagram_2.ht.

The Rose diagram window displays two statistical plots using the currently loaded fault 
coverage. The solid polygons represent the cumulative lengths of faults for each 10 degree 
range of strike orientations. The polygons are colored by slip tendency, dilation tendency, or 
leakage factor.  
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The dots represent the longest continuous fault length for each 10 degree range of strike 
orientations. At the bottom of the window, the maximum values for all fault strike 
orientations are displayed. The values represent lengths and are in the same units as the 
currently loaded fault coverage.
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- Toggle Viewing of Fields 

Change point size of continuous lengths.
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Rose Diagram Options 
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Surface Viewer 

The surface viewer displays slip tendency, dilation tendency, or leakage factor values 
computed in the Tendency Plot window as a 3D surface. The height and color of the surface 
represent the computed slip tendency, dilation tendency, leakage factor values. The vertical 
exaggeration of the surface is controlled by buttons on the Options window.

gage 2

10/30/00 10:33 AM



3dstres htLp:/i/oso.geophysics.swfi.eduM bwinfreyl3dstressthtnldocs/Sumface_Viewer 2.hti

page 1

C(5 
10/30/00 10:33 AM



-7
3dstress http://oso.geophysics.swri.edulbwinfrey/3dstressitmldocs/Surface Optbons.htL 

Surface Viewer Options

Opin,

The display option changes the 
rendering of the image using 
either a solid, line, or point style.

Dane 2
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Options 
The Options Window may be accessed by clicking on the Options Button on the Command 
Bar. The tools in this window allow the user to change the variable plotted in the Tendency 
Pott, change the color scheme of the graphics window, change the color detail, change the 
lighting scheme, change the color threshold, and toggle the verbosity mode.  

The user may change the variable plotted in the Tendency plot by clicking on the radio button 
next to the desired plot-type. See the following figure.

The user may also change the color scheme of the graphics window. The user may toggle 
between color and black-and-white plots for the graphics displays.

Also, the user may select a white or a black background for the graphics displays.  

The user may alter the detail used in the coloring of images by changing the step size setting 
and the color scale setting.

Step size controls the number of point of data drawn. The smaller the step size is, the more 
detailed the plot becomes. The color scale setting controls the gradient of the color scale. As 
the magnitude of the color scale setting increases the range of data colored by the color used 
for the largest data values increases.  

The user may alter certain lighting conditions by enabling the Enable Lighting toggle button.
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Enabling this toggle causes the lighting controls to appear just below it. The user may then 
alter the RGB value for the ambient light (light emitted by the objects themselves rather than 
by an external source) by moving the three sliders representing the amount of red, green, and 
blue that appearjust under the heading "Ambient Light". There are additional sliders for the 
RGB value of the Specular Color (the color illuminating the whole scene from an external 
source) of the graphic displays.

The Threshold option is the next option vertically after the Enable Lighting option. Like the 
Enable Lighting option, the Threshold option is a toggle button, i.e., it can either be set on or 
off.

The Threshold option is used to control the range of colors used on the legends of the 
graphics displays. When the toggle is set to "On", the sliders controlling the range of the 
legend colors appears.

The Verbose toggle button is the final button appearing vertically in the options window.  
When enabled, this button provides detailed information on the actual inner workings of 
3dstress. It is useful in determining the reason for sometimes esoteric system errors.
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Hot-Keys for Specific Windows 

Within specific windows, certain key-strokes may be used to issue commands. By taking note 
of the general consistency of these commands from window to window, the users may 
increase efficiency. This same information may be found in the Quick-Help option of the 
Help pull-down menus of most windows.  

Tendency Viewer Hot-Keys 

Mouse: 
"* <left button> Change slip tendency 
"* <middle button> Select triangles with similar strikes in 3D Viewer 
", <right button> Get the name of a selected overlay 

Keyboard: 
* (.) Increase strike 
* (,) Decrease strike 
"* (m) Increase dip 
"* (n) Decrease dip 
"* (p) Create xwd image of window 
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Hot-Keys for Specific Windows 

Within specific windows, certain key-strokes may be used to issue commands. By taking note 
of the general consistency of these commands from window to window, the users may 
increase efficiency. This same information may be found in the Quick-Help option of the 
Help pull-down menus of most windows.  

3D Viewer Hot-Keys 

Mouse: 
* <left button> Change position of viewer/selection 
e <middle button> Zoom in or out 
* <right button> Rotate the viewer 

Keyboard: 
e (b) Toggle showing of bounding box 
* (o) Zoom out 
9 (i) Zoom in 
* (r) Reset viewer 
• (Spacebar) Turn selection on 
* (a) Toggle showing of axis 
* (v) Average selected vectors 
* (m) Toggle between rotation modes 
* (z) Change render mode 
9 (p) Create xwd image of window 
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Hot-Keys for Specific Windows 

Within specific windows, certain key-strokes may be used to issue commands. By taking note 
of the general consistency of these commands from window to window, the users may 
increase efficiency. This same information may be found in the Quick-Help option of the 
Help pull-down menus of most windows.  

Map Viewer Hot-Keys 

Mouse: 
* <left button> Change position of map 
* <middle button> Zoom in or out 
* <right button> Select fault 

Keyboard: 
* (b) Toggle showing of bounding area 
- (o) Zoom out 
e (i) Zoom in 
* (r) Reset viewer 
o (p) Create xwd image of window 
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Hot-Keys for Specific Windows 

Within specific windows, certain key-strokes may be used to issue commands. By taking note 
of the general consistency of these commands from window to window, the users may 
increase efficiency. This same information may be found in the Quick-Help option of the 
Help pull-down menus of most windows.  

Rose Diagram Hot-Keys 

Mouse: 
9 <left button> change position of map 
9 <middle button> Zoom in or out 
9 <right button> Northing 

Keyboard: 
0 (o) Zoom out 
e (i) Zoom in 
9 (r) Reset viewer 
* (b) Toggle showing of bounding area 
9 (c) Toggle showing of continuous lengths 
e (s) Toggle showing of cumulative lengths 
e (p) Create xwd image of window 
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Hot-Keys for Specific Windows 

Within specific windows, certain key-strokes may be used to issue commands. By taking note 
of the general consistency of these commands from window to window, the users may 
increase efficiency. This same information may be found in the Quick-Help option of the 
Help pull-down menus of most windows.  

Surface Viewer Hot-Keys 

Mouse: 
* <left button> Nothing 
* <middle button> Zoom in or out 
* <right button> Rotate the viewer 

Keyboard: 
* (o) Zoom out 
* (i) Zoom in 
* (r) Reset viewer 
* (,) Increase vertical exaggeration 
* (.) Decrease vertical exaggeration 
• (a) Toggle showing of axis 
* (b) Toggle showing of bounding box 
* (u) Toggle showing of base 
* (x) Toggle showing of points 
* (z) Change render mode 
* (p) Create xwd image of window 
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Hot-Keys for Specific Windows 

Within specific windows, certain key-strokes may be used to issue commands. By taking note 
of the general consistency of these commands from window to window, the users may 
increase efficiency. This same information may be found in the Quick-Help option of the 
Help pull-down menus of most windows.  

Graph Hot-Keys 

Mouse: 
"* <left button> Change position of pointer 
"* <middle button> Nothing 
"* <right buttong> Change log mode 

Keyboard: 
"* (1) Change log mode 
"* (p) Create xwd image of window 
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Hot-Keys for Specific Windows 

Within specific windows, certain key-strokes may be used to issue commands. By taking note 
of the general consistency of these commands from window to window, the users may 
increase efficiency. This same information may be found in the Quick-Help option of the 
Help pull-down menus of most windows.  

Mohr Graph Hot-Keys 

Mouse: 
* <left button> Change position of graph 
* <middle button> Zoom in or out 
* <right button> Nothing 

Keyboard: 
* (a) Toggle showing of axis 
* (i) Zoom in 
• (o) Zoom out 
9 (r) Reset viewer 
* (x) Toggle showing of inner circles 
* (z) Change render mode 
* (p) Create xwd image of window 
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File Selector 

The file selector allows the loading or saving of files. Files may be selected by typing the 
name of the file in the Selection area or by double clicking on a file name in the Files section.  
Changing directories can be done by navigating through the file system by using the 
Directories section or typing in a new directory as the Filter.
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Some of the file selectors may contain a file type section which allows for loading or saving 
of different file formats by selecting the appropriate file type.  
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Example 

Use the following example to determine if 3DStress is installed correctly and heighten your 
level of understanding of the 3DStress application suite.  

Begin by opening the Mohr Graph Option window. Type 150 into the Max Value text box 
under the heading Sigma Range to increase the maximum allowable stress value. Now, 
change the magnitudes of , and to 133, 108, and 68 respectively via the 
Magnitude sliders immediately to the left of the Sigma Range box. Change the Fluid 
Pressure (in the Sigma Range Box below the Max and Min Value text boxes) to 43. The 
options window should now look like this
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The Mohr Graph should look like this

Click the Apply Button at the bottom of the Mohr Graph's Option window to transfer the 
stress relationships, the fluid pressure, and the automatically computed tensile strength to the 
rest of the application suite.  
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Note that the effective stresses from the Mohr Graph have been normalized to produce the 
new U, V, and W, 
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Open the Magnitude Tool window and change the V Direction slider to 28. The Magnitude 
Tool window should now look like this
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Before loading any files, open the Options window and change the Step Size to 1. The 
Options window should look like this
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The Tendency Plot should now look like this
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Open the 3D Fault Viewer and load the file fitOO_1bowRidgeO2O.flt (provided with the 
3dstress version 1.3 release). The 3D Fault Viewer should look like this
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Open the Map Viewer and load the fault file frizzell.lin and the coverage file 
worldutmzl 1lin (both provided with the 3dstress version 1.3 release as well). The Map 
Viewer should look like this

Page 6 age 8

10/30/00 10:36 AM

3d&t,,ss



3dsress
I

page 7 page9

030 
10/30100 10:36 AM

http://oso.geophysios.swri.edu/bwinfrey/3dstresstimldocs/Exmple_8.hu 

Now, zoom out using the middle mouse button to view the whole coverage.
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The Rose Diagram should look like this

RagC p age 10

10/30/00 10:36 AM

1

IoflI



http://oso.geophysics.swriedu/owinfrey/3dstresshtmldocs/Exampiel Ohtt

The Stress Ratio Graph should look like this
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Finally, Surface Viewer should look like this

This example is based on the following article: 

Morris, A., D. A. Fernill, and D. B. Henderson, 1996, "Slip-tendency analysis and fault 
reactivation," Geology, March 1996, 24(3): 275 278.  
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File Formats 

Introduction and Requirements

This appendix describes procedures used to enter two-dimensional (2D) fault traces (e.g., 
from maps) and 3D fault surfaces into 3DStress. To enter data Arc/Info , EarthVision , or 
3DMove must be available on the computer system.  

Fault Import Procedures for 3DStress 

The 3DStress application is capable of reading ASCII data files containing 2D fault trace data 
and 3D fault surfaces. The naming convention used by 3DStress developers is to suffix the 
2D fault trace files with .lin and the 3D fault surface files described below with .fIt, although 
3DStress does not require consistent file suffixes. 3DStress also reads the 3D fault files 
(usually suffixed with .vbl) produced by 3DMove . The .lin and .flt fault file format is similar 
to the format produced by the Arc/Info UNGENERATE command. The file is divided into 
sections that describe individual fault traces or segments as shown below.  

2D File Format

1 
xl, 
xl, 

xN, 
END 
2 
xl, 
x2, 

xN, 
END 
END

Yl 
y2 

yN 

y1 

y2 

yN

3D File Format

1 
xl, 
x2, 

xN, 
END 
2 
xl, 
x2, 

xN, 
END

yl, zl 
y2, z2

yN, ZN

yl, z1 
y2, z2 

yN, ZN
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END 

Generation of Fault Trace Files 

CNWRA generates 2D fault trace files directly using Arc/Info. Line coverages are converted 
to the ASCII file format using the Arc/Info UNGENERATE command. The resulting fault 
trace files are input directly to the 3DStress application. Arc/Info line coverages can be 
generated using several techniques described in the Arc/Info user documentation.  

Generation of Fault Surface Files 

CNWRA generates 3D fault surface files by post processing EarthVision fault grid files into 
the format described above. The steps required for this procedure are as follows. 1) Create a 
2D fault surface grid file with EarthVision . Grid the surface file using the exact data range, 
no z limits, and no extrapolation. High resolution grids generally give better results than low 
resolution grids. 2) Convert the 2D grid file to ASCII format using the script file 
run2grdToFlt generated by CNWRA. The run2grdToFlt script requires for successful 
execution that the Dynamic Graphics "evexport" program and license be located on the local 
system. The contents of the run2grdToFlt script file are listed below: 

# !/bin/sh 

if [ $# it 1 
then 

echo "\nUsage $0 [zmin zmax]" 
echo "$# of 1\n" 
exit 

fi 

gridfile=$1 
datfile='echo $gridfile nawk F"." '(print $1}''.goofy.dat 
tmplfile='echo Sgridfile nawk F"." '[print $l')'.tmpl 
tmp2file='echo Sgridfile nawk F"." '[print $1i''.tmp2 
tmp3file:'echo Sgridfile nawk F"." '[print $1)''.tmp3 
tmp4file='echo $gridfile nawk F"." '[print $l]''.tmp4 
linfile='echo $gridfile nawk F "." ' [print $11'' .flt 

echo "\nExport 2grd file to dat file \n" 
ev-export n o $datfile Sgridfile 

head 31 $datfile 

echo "\nConvert dat file to tmpl file \n" 
nawk '[ 

if (substr($0,1,1) "#") 
x= $1 + 0.0 
y = $2 + 0.0 
z = $3 + 0.0 
printf "% 14.6f %14.6f % 14.6f\n", x,y,z 

I 
]' $datfile > $tmplfile 

head 10 $tmp 1 file 

cp $tmp 1 file $tmp2file 

if [ $# eq 3] 
then 

echo "\nFilter tmpl file for z ranges \n"
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nawk '[ 
x =$1 +0.0 

y =$2 + 0.0 
z= $3 + 0.0 
if ((z >= zmin) && (z <= zmax)) ( 

printf "% 14.6f % 14.6f %14.6f\n", x,y,z 
I 

]' zmin=$2 zmax=$3 $tmp 1 file > $tmp2file 
head 10 $tmp2file 

fi 

echo "\nConvert dat file to flt file \n" 

nawk 'BEGIN 
cnt = 1 
xcntset - 0 

x[cnt] = $1 + 0.0 
y[cnt] = $2 + 0.0 
z[cnt] = $3

if (cnt > 1) 
if (!xcntset) [ 

if (y[cnt] ! = y[cnt 1]) 
xCnt = cnt 1 
xcntset = 1 
# print "Xcnt ' xCnt 

Cnt++ 

END 

yCnt = (cnt l)/xCnt 
# print "Ycnt = ", yCnt

for (yi = 0; yi < yCnt 1; yi++) [ 
vcnt = 0 
for (xi = 1; xi < xCnt; xi++) 

ind = xi + (yi*xCnt) 
ind2 = ind + xCnt 
if ((z[ind] != "NZRNG") && (z[ind2] 1- "NZRNG")) [ 

v[vcnt] = ind 
vcnt++ 
v[vcnt] = ind2 
vcnt++ 

if (vcnt > 2) 
printf "%4d\n", yi 

for (vi = 0; vi < vcnt; vi++) 
ind = v[vi] 
printf "%14.6f % 14.6f %s\n", x[ind], y[ind], z[ind] 

I 
printf "END\n" 

I 

printf "END\n'
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]' zmin=$2 zmax=$3 $tmp2file > $tmp3file 

echo "\nStrip null Z coordinates \n" 

nawk '( 
if (NF == 3) [ 

if ($3 != 0) ( 
x = $1 + 0.0 
y = $2 + 0.0 
z = $3 + 0.0 

printf "% 14.6f %14.6f % 14.6f\n", x,y,z 

else 
printf "%s\n", $1 

]'$tmp3file > $tmp4file 

head 10 $tmp4file 

echo "\nStrip segments with less than 3 coordinates \n" 

nawk 'BEGIN 
segStr=1, , 
lineCount=0 

if (segStr I="") 
segStr=segStr"\n" $0 

] else f 
segStr=segStr$0 

if (NF= 3) 
lineCount +- 1 

/END/ 
if (lineCount >3) [ 

print segStr 
I 
lineCount =0 
segStr="" 

I 
END [ 

print "END" 
]'$tmp4file > $linfile 

head 10 $1infile 

rm $datfile $tmplfile $tmp2file $tmp3file $tmp4file 

echo "\nFinished, created $linfile\n" 
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